描述
/青 春 是 用 来 追 忆 的
/当 你 怀 揣 着 她 时
/她 一 文 不 值
/只 有 将 她 耗 尽 后
/再 回 过 头 看
/一 切 才 有 了 意 义
/爱 过 我 们 的 人 和 伤 害 过 我 们 的 人
/都 是 我 们 青 春 存 在 的 意 义
在ACM中找寻青春的意义:
Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t = 4, n = 6, and the list is [4, 3, 2, 2, 1, 1], then there are four different sums that equal 4: 4, 3+1, 2+2, and 2+1+1. (A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.
输入
The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1, …, xn. If n = 0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12 (inclusive), and x1, …, xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.
输出
For each test case, first output a line containing ‘Sums of’, the total, and a colon. Then output each sum, one per line; if there are no sums, output the line ‘NONE’. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distinct; the same sum cannot appear twice.
输入样例 1
4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0
输出样例 1
Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25
题目比较长或者看不懂也没有关系,光看样例输入与输出也应该了解了题目意思,在给出的一些数中,能满足相加等于给定的值有哪些组合?这是比较常见的深度优先搜索问题。
下面给出具体代码实现:
#include<bits/stdc++.h>
using namespace std;
int n,flag,m;
int a[10001],b[10001];
void dfs(int deep,int sum,int length)
{
int i;
if(sum>n)
return;//表示数字的和比规定的数字大了返回上一层
else if(sum==n)
{
flag=1;
for(i=0; i<length; i++)
{
if(i==0)
printf("%d",b[i]);//输出方案
else
printf("+%d",b[i]);
}
cout<<endl;
}
for(i=deep; i<m; i++)
{
b[length]=a[i];//把可以进行方案组合的数组一个一个的给它
dfs(i+1,sum+a[i],length+1);//向下搜索,这里的总和是sum+a[i]是需要注意的
while(a[i]==a[i+1])//遇到同样的数需要继续往下走
i++;
}
}
int main()
{
int i;
while(cin>>n)
{
flag=0;
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
scanf("%d",&m);
if(n==0&&m==0)
break;
for(i=0; i<m; i++)
{
cin>>a[i];
}
printf("Sums of %d:\n",n);
dfs(0,0,0);
if(flag==0)
{
printf("NONE\n");
}
}
return 0;
}
希望对你有所帮助哦!