容器set与字符操作:UVA - 10815

Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful. You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like “Apple”, “apple” or “APPLE” must be considered the same.
Input
The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.
Output
Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.
Sample Input
Adventures in Disneyland
Two blondes were going to Disneyland when they came to a fork in the road. The sign read: “Disneyland Left.”
So they went home.
Sample Output
a
adventures
blondes
came
disneyland
fork
going
in
left
read
road
so
the
they
to
went
were
when
伪代码
一个元素为字符串的集合s
一个字符串变量str
while(读入一行字符串指导文件的末尾){
for(从字符串的第一个元素到最后一个元素进行查找){
if(找到一个为字符的元素)
将从该字符开始到接下来连续的字符转换为小写字母构成字符串存入到集合s中
/集合s中的元素具有唯一性,以及按从小到达排序/
}
输出s中的所有元素
}
代码

#include<iostream>
#include<string>
#include<set>
using namespace std;
set<string> s;
int main(){
    string str;
    while(getline(cin,str)){
        for(int i=0;i<str.size();i++){
            if(!isalpha(str[i]))continue;
            string temp;
            while(isalpha(str[i])){
                temp+=tolower(str[i]);
                i++;
            }
            s.insert(temp);
        }
    }
    for(set<string>::iterator i=s.begin();i!=s.end();i++)
        cout<<*i<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值