Kruskal算法:最小生成树1 POJ - 1251 题解

这里写图片描述
Description
The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

Input
The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.
Output
The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.
Sample Input
9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0
Sample Output
216
30
题目概要
由题目所给出的无向图求出其所对应的最小生成树。
每一行的第一个字母为起始顶点,紧接这的数字为与该顶点直接相连的顶点,接着给出端点和边的权值。已经给过的边不会重复给出。求出最小生成树的权值。
题目解析

char u[76], v[76], p[27];
int w[76], r[76];
/*u[j],v[j]对应一条边的两个顶点
p[u]对应顶点所在的并查集的结合,由该集合的根节点字母代表。
w[j]为该边的权重
r[j]代表该边在所有边中的由小到大的排序序号*/
int cmp(const int i, const int j){
    return w[i] < w[j];
}
//cmp用于边的大小排序。
char find(char x){ return p[x-65] == x ? x : p[x-65] = find(p[x-65]); }
//查找顶点所在集合
主函数
1.根据边长对边进行排序
2.查找每条边的顶点是否在同一个集合内,如果不在同一个集合内则将集合合并,并将权值累计到最终结果中
3.输出最终结果。

代码

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
char u[76], v[76], p[27];
int w[76], r[76];
int cmp(const int i, const int j){
    return w[i] < w[j];
}
char find(char x){ return p[x-65] == x ? x : p[x-65] = find(p[x-65]); }
int main(){
    int n;
    while (scanf("%d", &n)){
        if (n == 0)break;
        int m=0;//边的条数
        for (int i = 0; i < n - 1; i++){
            int k;
            cin >> p[i];
            cin >> k;
            while (k--){
                u[m] = p[i];
                cin >> v[m] >> w[m];
                m++;
            }
        }
        p[n-1] = p[n-2] + 1;
        for (int i = 0; i < m; i++)
            r[i] = i;
        sort(r, r + m, cmp);
        int ans = 0;
        for (int i = 0; i < m; i++){
            int e = r[i];
            char x = find(u[e]);
            char y = find(v[e]);
            if (x != y){ ans += w[e]; p[x-65] = y; }
        }
        cout << ans << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值