HDU3605 Escape —— 二分图多重匹配

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3605


Escape

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 10349    Accepted Submission(s): 2476


Problem Description
2012 If this is the end of the world how to do? I do not know how. But now scientists have found that some stars, who can live, but some people do not fit to live some of the planet. Now scientists want your help, is to determine what all of people can live in these planets.
 

Input
More set of test data, the beginning of each data is n (1 <= n <= 100000), m (1 <= m <= 10) n indicate there n people on the earth, m representatives m planet, planet and people labels are from 0. Here are n lines, each line represents a suitable living conditions of people, each row has m digits, the ith digits is 1, said that a person is fit to live in the ith-planet, or is 0 for this person is not suitable for living in the ith planet.
The last line has m digits, the ith digit ai indicates the ith planet can contain ai people most..
0 <= ai <= 100000
 

Output
Determine whether all people can live up to these stars
If you can output YES, otherwise output NO.
 

Sample Input
  
  
1 1 1 1 2 2 1 0 1 0 1 1
 

Sample Output
  
  
YES NO



题解:

二分图多重匹配的裸题,但要适当修改以防止超时。



代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <string>
#include <set>
#define ms(a,b) memset((a),(b),sizeof((a)))
//#define LOCAL
using namespace std;
typedef long long LL;
const int INF = 2e9;
const LL LNF = 9e18;
const int mod = 1e9+7;
const int maxn = 1e5+10;

int n, m;
int linker[20][maxn];
int g[maxn][20];
bool used[20];
int num[20];

bool dfs(int u)
{
    for(int v = 1; v<=m; v++)
    if(g[u][v] && !used[v])
    {
        used[v] = true;
        if(linker[v][0] < num[v])
        {
            linker[v][++linker[v][0]] = u;
            return true;
        }
        for(int i = 1; i<=num[v]; i++)
        if(dfs(linker[v][i]))
        {
            linker[v][i] = u;
            return true;
        }
    }
    return false;
}

int hungary()
{
    for(int v = 1; v<=m; v++)
        linker[v][0] = 0;
    for(int u = 1; u<=n; u++)
    {
        memset(used,0,sizeof(used));
        if(!dfs(u)) return 0; //如果这个人匹配不到,则直接退出。否则会超时。
    }
    return 1;
}

int main()
{
#ifdef LOCAL
    freopen("123", "r", stdin);
//      freopen("output.txt", "w", stdout);
#endif

    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(int i = 1; i<=n; i++)
        for(int j = 1; j<=m; j++)
            scanf("%d",&g[i][j]);
        for(int i = 1; i<=m; i++)
            scanf("%d",&num[i]);
        if(hungary()) puts("YES");
        else puts("NO");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值