HDU 2709 Sumsets —— 递推

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2709


Sumsets

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3094    Accepted Submission(s): 1225


Problem Description
Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).
 

Input
A single line with a single integer, N.
 

Output
The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).
 

Sample Input
  
  
7
 

Sample Output
  
  
6



题解:

此题的关键是以“1”作为讨论对象。

1.当n为奇数时,即比n-1多了一个1,且至少有一个1,。那么相当于在n-1的所有情况中,在加多一个1。所以:dp[n] = dp[n-1]

2.当n为偶数时:如果有1,那么至少有两个1,这就相当于在dp[n-2]的所有情况下加多两个1,所以dp[n] += dp[n-2];如果没有1,那么每一项都是2的倍数,即dp[n/2]每种情况的每一项都乘上2,所以dp[n] += dp[n/2]。综上:dp[n] = dp[n-2] + dp[n/2]。




代码如下:

#include <bits/stdc++.h>
#define rep(i,s,t) for(int (i)=(s); (i)<=(t); (i)++)
#define ms(a,b) memset((a),(b),sizeof((a)))
using namespace std;
typedef long long LL;
const int INF = 2e9;
const LL LNF = 9e18;
const double eps = 1e-6;
const int mod = 1e9;
const int maxn = 1e6+10;

LL n,dp[maxn];

int main()
{
    dp[0] = 1;
    rep(i,1,maxn-1)
    {
        if(i%2)
            dp[i] = dp[i-1];
        else
            dp[i] = (dp[i-2] + dp[i/2])%mod;
    }
    while(cin>>n)
        cout<<dp[n]<<endl;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值