HDU5171 GTY's birthday gift —— 矩阵快速幂

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5171


GTY's birthday gift

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1654    Accepted Submission(s): 649


Problem Description
FFZ's birthday is coming. GTY wants to give a gift to ZZF. He asked his gay friends what he should give to ZZF. One of them said, 'Nothing is more interesting than a number multiset.' So GTY decided to make a multiset for ZZF. Multiset can contain elements with same values. Because GTY wants to finish the gift as soon as possible, he will use JURUO magic. It allows him to choose two numbers a and b( a,bS ), and add  a+b  to the multiset. GTY can use the magic for k times, and he wants the sum of the multiset is maximum, because the larger the sum is, the happier FFZ will be. You need to help him calculate the maximum sum of the multiset.
 

Input
Multi test cases (about 3) . The first line contains two integers n and k ( 2n100000,1k1000000000 ). The second line contains n elements  ai  ( 1ai100000 )separated by spaces , indicating the multiset S .
 

Output
For each case , print the maximum sum of the multiset ( mod 10000007 ).
 

Sample Input
  
  
3 2 3 6 2
 

Sample Output
  
  
35




题解:

可以推出斐波那契数列,那么就用矩阵快速幂求前n项,以及前n项和。







代码如下:

#include <bits/stdc++.h>
#define rep(i,s,t) for(int (i)=(s); (i)<=(t); (i)++)
#define ms(a,b) memset((a),(b),sizeof((a)))
using namespace std;
typedef long long LL;
const int INF = 2e9;
const LL LNF = 9e18;
const double eps = 1e-6;
const int mod = 10000007;
const int maxn = 100000+10;

int n,k;
int a[maxn];

struct MAT
{
    LL mat[5][5];
    void init() {
        rep(i,1,3) rep(j,1,3)
            mat[i][j] = (i==j);
    }
};

MAT mul(MAT x, MAT y)
{
    MAT s;
    ms(s.mat,0);
    rep(i,1,3)  rep(j,1,3) rep(k,1,3)
        s.mat[i][j] += (1LL*x.mat[i][k]*y.mat[k][j])%mod, s.mat[i][j] %= mod;
    return s;
}

MAT qpow(MAT x, int y)
{
    MAT s;
    s.init();
    while(y)
    {
        if(y&1)  s = mul(s,x);
        x = mul(x,x);
        y >>= 1;
    }
    return s;
}

int main()
{
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        rep(i,1,n)
            scanf("%lld",&a[i]);

        sort(a+1,a+1+n);
        LL ans = 0;
        rep(i,1,n)
            ans += a[i], ans %= mod;

        MAT s;
        ms(s.mat,0);
        s.mat[1][1] = s.mat[1][2] = s.mat[1][3] = 1;
        s.mat[2][2] = s.mat[2][3] = s.mat[3][2] = 1;
        s = qpow(s,k-2);

        ans += (1LL*(2*a[n-1]+3*a[n])*s.mat[1][1])%mod, ans %= mod;
        ans += (1LL*(1*a[n-1]+2*a[n])*s.mat[1][2])%mod, ans %= mod;
        ans += (1LL*(1*a[n-1]+1*a[n])*s.mat[1][3])%mod, ans %= mod;
        cout<<ans<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值