POJ3278 Catch That Cow —— BFS

题目链接:http://poj.org/problem?id=3278


Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 97563 Accepted: 30638

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source





题解:

一开始以为是数学找规律,但是看到数据范围很小,n<=1e5,可以用数组存;而且题目要求的是“最少步数”,而“最少步数”经常都是用BFS求的。再将BFS的思想带入看看,发现可以解决问题。

在第一次提交时,RUNTIME ERROR了。但是再看看代码,数组没有开小,不是数组的问题。后来发现再判断某个位置是否vis时,先判断了是否vis,然后再判断这个位置是否合法,这样会导致数组溢出,所以问题就出现在这里了,需谨慎!!


代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <vector>
#include <queue>
#include <stack>
#include <map>
#include <string>
#include <set>
#define ms(a,b) memset((a),(b),sizeof((a)))
using namespace std;
typedef long long LL;
const int INF = 2e9;
const LL LNF = 9e18;
const int MOD = 1e9+7;
const int MAXN = 1e5+10;

int vis[MAXN];

struct node
{
    int val, step;
};

queue<node>que;
int bfs(int n, int k)
{
    ms(vis,0);
    while(!que.empty()) que.pop();

    node now, tmp;
    now.val = n;
    now.step = 0;
    vis[n] = 1;
    que.push(now);

    while(!que.empty())
    {
        now = que.front();
        que.pop();

        if(now.val==k)
            return now.step;

        tmp.step = now.step+1;
        if(now.val+1>=0 && now.val+1<=1e5 && !vis[now.val+1] )  //先判断范围再判断vis !!!
            vis[now.val+1] = 1, tmp.val = now.val+1, que.push(tmp);
        if(now.val-1>=0 && now.val-1<=1e5 && !vis[now.val-1] )
            vis[now.val-1] = 1, tmp.val = now.val-1, que.push(tmp);
        if(now.val*2>=0 && now.val*2<=1e5 && !vis[now.val*2] )
            vis[now.val*2] = 1, tmp.val = now.val*2, que.push(tmp);
    }
}

int main()
{
    int n, k;
    scanf("%d%d",&n, &k);
    cout<< bfs(n,k) <<endl;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值