poj 3278 Catch That Cow——bfs

Catch That Cow

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input

5 17
Sample Output
4
Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题意: 从N出发到K的最少的行进的步数,行进的方法有以下三种:

  • 前进1步,当前位置x加1
  • 退后1步,当前位置x减1
  • 前进x步,当前位置x乘以2(x*2)

题解: 直接bfs,从三个方向进行搜索,简单题。

c++ AC 代码

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<queue>
using namespace std;
const int MAX = 1000000;

int s,e;
bool vis[MAX];

struct Point
{
	int pos;
	int step;
};

bool is_in_map(int x)
{
	if(0 <= x && x < MAX && !vis[x])
		return 1;
	return 0;
}


int bfs()
{
	queue<Point> que;
	Point start;
	start.pos = s;
	start.step = 0;
	vis[s] = 1;
	que.push(start);
	
	while(que.size())
	{
		Point p = que.front();
		
		if(p.pos == e)
			return p.step;
		
		Point now;
		now.pos = p.pos - 1;
		if(is_in_map(now.pos))
		{
			vis[now.pos] = 1;
			now.step = p.step + 1;
			que.push(now);
		}
		
		now.pos = p.pos + 1;
		if(is_in_map(now.pos))
		{
			vis[now.pos] = 1;
			now.step = p.step + 1;
			que.push(now);
		}
		
		now.pos = p.pos * 2;
		if(is_in_map(now.pos))
		{
			vis[now.pos] = 1;
			now.step = p.step + 1;
			que.push(now);
		}
		
		que.pop();
	}
	return -1;
}



int main()
{
	memset(vis,0,sizeof(vis));
	scanf("%d%d",&s,&e);
	printf("%d\n",bfs());
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值