[UVA]Wooden Sticks

Wooden Sticks

Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l’ and weight w’ if l <= l’ and w <= w’. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,…, ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1

Sample Output

2
1
3

Source

Taejon 2001

Solution

对n个木桩进行双标准排序(先满足长度,在满足重量),之后贪心策略为每次找出一组木桩,使组内满足li<=li+1,且wi<=wi+1,这样组内的木桩就不需要重新安装,剩下的木桩再进行寻找,直到所有木桩都属于某个组。

  • 代码
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
using namespace std;

const int Inf = 2147483647;
const int maxn = 5005;
struct wooden_stick {
    int l, w;
}s[maxn];
int n, ans;
bool vis[maxn];

inline bool cmd(const wooden_stick s1, const wooden_stick s2) 
{
    if(s1.l > s2.l) return true;
    else if(s1.l == s2.l && s1.w > s2.w) return true;
    return false;
}

int main()
{
    freopen("input.in", "r", stdin);
    freopen("output.out", "w", stdout);
    int T;
    scanf("%d", &T);
    while(T--) {
      scanf("%d", &n);
      for(int i = 1; i <= n; i++)
        scanf("%d%d", &s[i].l, &s[i].w);
      sort(s + 1, s + n + 1, cmd); //双标准排序
      memset(vis, 0, sizeof(vis));
      ans = 0;
      for(int i = 1; i <= n; i++)
        if(!vis[i]) {
          vis[i] = true;
          ans++;
          int l = s[i].l, w = s[i].w;
          for(int j = i + 1; j <= n; j++) //寻找一组木桩
            if(!vis[j] && s[j].l <= l && s[j].w <= w) {
              vis[j] = true;
              l = s[j].l; w = s[j].w;
            }  
        } 
      printf("%d\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值