FZU 1901 KMP找前后缀等串


Period II
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

For each prefix with length P of a given string S,if

S[i]=S[i+P] for i in [0..SIZE(S)-p-1],

then the prefix is a “period” of S. We want to all the periodic prefixs.

Input

Input contains multiple cases.

The first line contains an integer T representing the number of cases. Then following T cases.

Each test case contains a string S (1 <= SIZE(S) <= 1000000),represents the title.S consists of lowercase ,uppercase letter.

Output

For each test case, first output one line containing "Case #x: y", where x is the case number (starting from 1) and y is the number of periodic prefixs.Then output the lengths of the periodic prefixs in ascending order.

Sample Input

4oooacmacmacmacmacmafzufzufzufstostootssto

Sample Output

Case #1: 31 2 3Case #2: 63 6 9 12 15 16Case #3: 43 6 9 10Case #4: 29 12

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
using namespace std;
int nex[1000005];
int k;
int ans[1000005];
void pre(string str){
    nex[0]=-1;
    int i=0,j=-1;
    while(i<str.size()){
        if(j==-1||str[i]==str[j]){
            j++;i++;
            nex[i]=j;
        }else
            j=nex[j];
    }
}
void kmp(string str){
    pre(str);
    int len=str.size();
    int i=len-1;
    k=0;
    while(i>-1){
        if(str[i]==str[len-1]) ans[k++]=len-i-1;
        i=nex[i];
    }
}
int main()
{
    std::cout.sync_with_stdio(false);
    string str;
    int n;
    while(cin>>n){
        for(int t=1;t<=n;t++){
            cin>>str;
            kmp(str);
            cout<<"Case #"<<t<<": "<<k<<endl;
            for(int i=1;i<k;i++)
                cout<<ans[i]<<' ';
            cout<<str.size()<<endl;
        }
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值