大数取余

基础练习(一)
12:00:00
               
C - Big Number
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B. 

To make the problem easier, I promise that B will be smaller than 100000. 

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines. 
 

Input

The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file. 
 

Output

For each test case, you have to ouput the result of A mod B. 
 

Sample Input

       
       
2 3 12 7 152455856554521 3250
 

Sample Output

       
       
2 5 1521
 

题意:求大数的余数

思路:从低位向高位依次取余 循环操作  

            主要运用 了同余定理:

                                                      1.(a+b)%c=(a%c+b%c)%c

                                                       2.(a*b)%c=((a%c)*(b%c))%c

             定理的理解暂时借助一次函数图像

             1,2综合运用可推出快速幂。

代码如下:

#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;

int   kuaisumi(int x,int l,int b,int i)//快速幂取模

{
int y=l-i-1,m=1,k=10;
k%=b;
while(y!=0)
{
if(y%2==0)
{
y/=2;
k=k*k%b;
}
else
{
--y;
m=m*k%b;
}
}
m=((m%b)*(x%b))%b;
return m;
}
int main()
{
int b,i,j,k,l,t,max,m;
char a[1111];
   
    while( scanf("%s %d",a,&b)!=EOF)//调试过程中出现余数为负的结果 暂时不能解释
{
   l=i=strlen(a);
   --i;
   m=a[i]-'0';
   --i;
   while(i>=0)
   {
    m=(m%b+kuaisumi(a[i]-'0', l, b, i)%b)%b;
    --i;
}
printf("%d\n",m);
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值