C - Labyrinth
Time Limit:2000MS Memory Limit:32768KB 64bit IO Format:%lld & %llu
Submit
Status
Description
The northern part of the Pyramid contains a very large and complicated labyrinth. The labyrinth is divided into square blocks, each of them either filled by rock, or free. There is also a little hook on the floor in the center of every free block. The ACM have found that two of the hooks must be connected by a rope that runs through the hooks in every block on the path between the connected ones. When the rope is fastened, a secret door opens. The problem is that we do not know which hooks to connect. That means also that the neccessary length of the rope is unknown. Your task is to determine the maximum length of the rope we could need for a given labyrinth.
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers C and R (3 <= C,R <= 1000) indicating the number of columns and rows. Then exactly R lines follow, each containing C characters. These characters specify the labyrinth. Each of them is either a hash mark (#) or a period (.). Hash marks represent rocks, periods are free blocks. It is possible to walk between neighbouring blocks only, where neighbouring blocks are blocks sharing a common side. We cannot walk diagonally and we cannot step out of the labyrinth.
The labyrinth is designed in such a way that there is exactly one path between any two free blocks. Consequently, if we find the proper hooks to connect, it is easy to find the right path connecting them.
Output
Your program must print exactly one line of output for each test case. The line must contain the sentence “Maximum rope length is X.” where Xis the length of the longest path between any two free blocks, measured in blocks.
Sample Input
2
3 3
###
#.#
###
7 6
#######
#.#.###
#.#.###
#.#.#.#
#.....#
#######
Sample Output
Maximum rope length is 0.
Maximum rope length is 8.
Hint
Huge input, scanf is recommended.
If you use recursion, maybe stack overflow. and now C++/c ‘s stack size is larger than G++/gcc
- 题意:给你一个迷宫:#代表不能走,点代表能走。问你两个”.“之间的最大距离。(只能走上下左右四个方向)
- 思路:bfs求最长路就是求树的直径,随便选一个起始点,跑一遍找到一个最远点,再以最远点为节点跑一遍找到另一端点直径。
- 失误:图的存储:边数多时用矩阵(地图存储),少时用邻接表(如树的存储),这一题就告诉我能用%s,就不用%c,超时硬伤!!!
- 代码如下:
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
const int MAXN=1e3+10;
char map[MAXN][MAXN];
bool vis[MAXN][MAXN];
int ans,ex,ey,c,r;
int dir[4][2]={
1,0,
-1,0,
0,1,
0,-1
};
struct node{
int x;
int y;
int step;
};
bool judge(node go)
{
bool a=go.x>=1&&go.x<=r;
bool b=go.y>=1&&go.y<=c;
bool c=!vis[go.x][go.y]&&map[go.x][go.y]!='#';
return a&&b&&c;
}
void bfs(int x,int y)
{
memset(vis,false,sizeof(vis));
node spos; spos.x=x; spos.y=y; spos.step=0;
vis[x][y]=true; ans=0;
queue<node> que;
que.push(spos);
while(!que.empty())
{
node now=que.front(); que.pop();
for(int i=0;i<4;++i)
{
node go; go.x=now.x+dir[i][0]; go.y=now.y+dir[i][1];
if(judge(go))
{
go.step=now.step+1;
vis[go.x][go.y]=true;
if(go.step>ans)
{
ans=go.step;
ex=go.x;
ey=go.y;
}
que.push(go);
}
}
}
}
int main()
{
int i,j,t,sx,sy;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&c,&r);
//getchar();
bool flag=true;
for(i=1;i<=r;++i)
{
scanf("%s",map[i]+1);//用%s就不超时了 %c就超时
if(flag) //加上这个 快100多毫秒 下面有图
{
for(int j=1;map[i][j]!='\0';++j)
{
if(map[i][j]=='.')
{
sx=i;
sy=j;
flag=false;
}
}
}
}
bfs(sx,sy);
bfs(ex,ey);
printf("Maximum rope length is %d.\n",ans);
}
return 0;
}