HDU-3655 Seaside 【有向图+dijkstra】

G - Seaside

Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit

Status

Practice

HDU 3665
Description
XiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting them. It is guaranteed that you can reach any town from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest way.
Input
There are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1) and Pi, then Mi lines followed. Mi means there are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers S Mi and L Mi, which means that the distance between the i-th town and the S Mi town is L Mi.
Output
Each case takes one line, print the shortest length that XiaoY reach seaside.
Sample Input
5
1 0
1 1
2 0
2 3
3 1
1 1
4 100
0 1
0 1
Sample Output
2


  1. 题意:一个人想去海边,她所在得村庄号为0,第一个数字5代表有5个村庄(0-4),接下来有5块信息,每块第一行有两个数,第一个数表示以第i村庄为起点的道路数,第二个数字表示此村庄是否在海边,0代表不在海边,1代表在海边,i表示第i块信息,接下来就是道路,第一个数代表该路的终点,第二个数是长度,求到海边的最短路是多少;
  2. 思路:就是要求0号村庄和海边村庄的最短距离,一个点确定,一个点部确定,我们应该将所有终点找出来保存起来,就是求一点与点之间的最短距离,用dijkstra较好,求出来后比较得出最小值;
  3. 失误:读懂题意,有向图;
  4. 代码如下:

#include<cstdio>
#include<cstring>
using namespace std;

#define inf 0xfffffff
const int MAXN=1e3+10;
int map[MAXN][MAXN],dis[MAXN];
bool vis[MAXN];
int e[MAXN];//保存终点节点

void dijkstra(int n)
{
    memset(vis,false,sizeof(vis));
    for(int i=0;i<n;++i)  dis[i]=map[0][i];
    dis[0]=0;
    for(int i=0;i<n;++i)
    {
        int top=inf,k;
        for(int j=0;j<n;++j)
        {
            if(!vis[j]&&dis[j]<top)
            {
                top=dis[j]; k=j;
            }
        }
        vis[k]=true;
        for(int j=0;j<n;++j)
        {
            if(!vis[j]&&dis[j]>dis[k]+map[k][j])
            {
                dis[j]=dis[k]+map[k][j];
            }
        }
    }
}

int main()
{   
    int n,i,j,v,w,cnt,mi,pi,ans;
    while(~scanf("%d",&n))//主要是数据的输入处理太麻烦了 应该弄清晰 
    {
        for(i=0;i<n;++i)//还有就是有向图要注意 
        for(j=0;j<n;++j)  map[i][j]=i==j?0:inf;

        cnt=0;
        for(i=0;i<n;++i)
        {
            scanf("%d %d",&mi,&pi);
            for(j=1;j<=mi;++j)
            {
                scanf("%d %d",&v,&w);
                if(map[i][v]>w)
                map[i][v]=w;
            }
            if(pi==1) e[++cnt]=i;
        }
        dijkstra(n);ans=inf;
        for(i=1;i<=cnt;++i)
        {
            ans=ans<dis[e[i]]?ans:dis[e[i]];
        }
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值