HDU-5137 H - How Many Maos Does the Guanxi Worth

H - How Many Maos Does the Guanxi Worth

Time Limit:1000MS Memory Limit:512000KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
“Guanxi” is a very important word in Chinese. It kind of means “relationship” or “contact”. Guanxi can be based on friendship, but also can be built on money. So Chinese often say “I don’t have one mao (0.1 RMB) guanxi with you.” or “The guanxi between them is naked money guanxi.” It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things.

Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance, someone may make their children enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu’s guanxi net consists of N people including Boss Liu and the schoolmaster. In this net, two persons who has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A “big money” means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net – it means that if there is a guanxi between A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help …… If the request finally reaches the schoolmaster, Boss Liu’s kid will be accepted by the middle school. Of course, all helpers including the schoolmaster are paid by Boss Liu.

You hate Boss Liu and you want to undermine Boss Liu’s plan. All you can do is to persuade ONE person in Boss Liu’s guanxi net to reject any request. This person can be any one, but can’t be Boss Liu or the schoolmaster. If you can’t make Boss Liu fail, you want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely succeed.
Input
There are several test cases.

For each test case:

The first line contains two integers N and M. N means that there are N people in Boss Liu’s guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N. M means that there are M guanxis in Boss Liu’s guanxi net. (3 <=N <= 30, 3 <= M <= 1000)

Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.

The input ends with N = 0 and M = 0.

It’s guaranteed that Boss Liu’s request can reach the schoolmaster if you do not try to undermine his plan.
Output
For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print “Inf” instead.
Sample Input
4 5
1 2 3
1 3 7
1 4 50
2 3 4
3 4 2
3 2
1 2 30
2 3 10
0 0
Sample Output
50
Inf


  1. 题意:a要找b帮忙,给出了多对关系,每对关系要帮忙都需要一定数量的钱,你可以说服除a,b外的一个人不帮忙。问你去掉一个人后使a花的最少钱的最大化是多少。(如果a不能通过关系找到b,输出Inf)
  2. 思路:求出最少钱用最短路求,又要去除一个人后的最小值的最大的那一个,那就枚举去除的人,求出去除后的最小值,将所有的最小值算出来后比较,保存最大的那一个。
  3. 失误:刚开始没想枚举,怕超时,我想去掉的肯定是现在最短路中的一个点,将最短路上的所有点保存起来,然后枚举去除最短路上的点。不过发现处理好麻烦。最后还是放弃了。用下面这代码一交,才15ms.无语。考虑麻烦了。。。
  4. 代码如下:

#include<cstdio>
#include<cstring>
using namespace std;

#define inf 0x3f3f3f3f
const int MAXN=1e3+10;
int  map[MAXN][MAXN],dis[MAXN];
bool vis[MAXN];
int mark[MAXN],jj[MAXN];

void dijkstra(int n)
{
    memset(vis,false,sizeof(vis));// memset(dis,inf,sizeof(dis)); 
    for(int i=1;i<=n;++i)  dis[i]=map[1][i];
    dis[1]=0;   
    for(int i=1;i<=n;++i)
    {
        int top=inf,k;
        for(int j=1;j<=n;++j)
        {
            if(!vis[j]&&dis[j]<top)
            {
                top=dis[j]; k=j;
             } 
        }
        vis[k]=true;  
        for(int j=1;j<=n;++j)
        {
            if(!vis[j]&&dis[j]>dis[k]+map[k][j])
            {
                dis[j]=dis[k]+map[k][j];
            }   
        }
    }
} 

int main()
{
    int ans,i,j,m,n,u,v,w;
    while(~scanf("%d %d",&n,&m),m||n)
    {

        for(i=1;i<=n;++i)
        for(j=1;j<=n;++j) map[i][j]=i==j?0:inf;//能过但最好别用 
        for(i=1;i<=m;++i)
        {
            scanf("%d %d %d",&u,&v,&w);
            if(map[u][v]>w)
            map[u][v]=map[v][u]=w; 
        }
        ans=0;    
        for(i=2;i<n;++i)//枚举去除的点 
        {
            for(j=1;j<=n;++j)//将去除的点和其他点的距离设为inf 
            {
                jj[j]=map[i][j];
                map[i][j]=map[j][i]=inf;
            }
            dijkstra(n);
            ans=ans>dis[n]?ans:dis[n];
            for(j=1;j<=n;++j)//还原 
            {
                map[i][j]=map[j][i]=jj[j];
            }
        }
        if(ans==inf)  printf("Inf\n");
        else  printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值