POJ 3630 Phone List 【判断串是否是其他串的前缀】

Phone List
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 28119 Accepted: 8412

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

题意:给定字符串集合,判断是否有某个串为别的串的前缀;


思路:构造出Trie,然后枚举每一个串判断这个串是否为其他串的前缀,枚举所有即可;


失误:1.数组开小了,少了一位,一直runtime error; 

      2.过了一下940ms 看宇神的思路一样他的就一百多秒,又是数组开大了,改小之后明显时间空间都小了,看来数组开的也要适度;


AC代码:

#include<cstdio>
#include<cstring>

struct tree{
	int num;
	int son[17];
}Node[110111];
char S[10111][14];
int sn=0;

void init()
{
	memset(Node,0,sizeof(Node)); sn=0;
}
void insert(char *str)
{
	int i=0,p=0;
	while(str[i]) {
		int pos=str[i]-'0';
		if(Node[p].son[pos]==0) 
		   Node[p].son[pos]=++sn;
		p=Node[p].son[pos]; ++i;
		++Node[p].num;
	}
} 	
bool Query(char *str)
{
	int i=0,p=0;
	while(str[i]) {
		int pos=str[i]-'0';
		p=Node[p].son[pos]; ++i;
		if(Node[p].num==1) 
		   return true;
	}
	return Node[p].num>1?false:true;
}
int main()
{
	int T,i,N;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&N); init();
		int i=0,cnt=0;
		for(i=1;i<=N;++i) 
		{
			scanf("%s",S[++cnt]); 
			insert(S[cnt]);
		}
		bool falg=false;
		for(i=1;i<=N;++i)
		{
			if(!Query(S[i])) {
				falg=true;  break;
			}
		}
		if(falg) printf("NO\n");
		else printf("YES\n");
	}
	return 0;
} 
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值