【二分匹配】HDU 1150 Machine Schedule

Machine Schedule

Problem Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.

Output

The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input

 
 
5 5 10 0 1 1 1 1 2 2 1 3 3 1 4 4 2 1 5 2 2 6 2 3 7 2 4 8 3 3 9 4 3 0

Sample Output

 
 
3

题意:有一类机器,它有很多个档,每换一次档要重启,重启和开机时间都是1,现在给两个机器输入n,m分别为两机器的档数,输入k为任务数,下面k行,每行第一个数是序号(没啥用),后两个表示这个任务可以由A机器的i档或B机器的j档来完成。最后求完任务在开机和重启的最小时间花费是多少。

其实就是求最小切换次数包括第一次开机,也就是求两台机器最少有几个档用上了,就是从A最少档数和B最少档数取一个更多的,由于每个任务都必须由两个的其中一个来完成,就可以转化成二分图求最大匹配数。这个匹配数就是最小的利用档数,这种情况下,表示每一个匹配之间都有任务,去掉其中一个档不影响总档数,去掉两个则不能完成任务,所以不能再小了。

#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 102
using namespace std;
int n,m,k;
bool map[N][N],vis[N];
int last[N];

int find(int i)
{
    int j;
    for(j=1;j<=m;j++)
    {
        if(map[i][j]&&!vis[j])
        {
            vis[j]=1;
            if(last[j]==-1||find(last[j]))
            {
                last[j]=i;
                return 1;
            }
        }
    }
    return 0;
}

int main()
{
    int i,t,a,b;
    while(~scanf("%d",&n)&&n)
    {
        scanf("%d%d",&m,&k);
        memset(map,0,sizeof(map));
        for(i=1;i<=k;i++)
        {
            scanf("%d%d%d",&t,&a,&b);
            map[a][b]=1;
        }
        memset(last,-1,sizeof(last));
        int sum=0;
        for(i=1;i<=n;i++)
        {
            memset(vis,0,sizeof(vis));
            if(find(i))
            sum++;
        }
        printf("%d\n",sum);
    }
    return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值