HDU 1007 Quoit Design

Quoit Design


Problem Description
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.
 

Input
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.
 

Output
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places.
 

Sample Input
  
  
2 0 0 1 1 2 1 1 1 1 3 -1.5 0 0 0 0 1.5 0
 
Sample Output
  
  
0.71 0.00 0.75


题意:输入一个数N,有N个点,找出距离最近的两个点,点数可能多达100000个。

数据量很大,这就需要优化了,先按横坐标排序,递归求最短的,筛选出可能的结果,再按纵坐标排序,再筛选。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int n;
struct point
{
    double x;
    double y;
};
point p[100002],ans[100002];
bool cmpx(point a,point b)
{
    return a.x<b.x;
}

bool cmpy(point a,point b)
{
    return a.y<b.y;
}

double dis(point a,point b)
{
    return (a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y);
}

double clo(int a,int b)
{
    if(a+1==b)
    return dis(p[a],p[b]);
    if(a+2==b)
    return min(dis(p[a],p[a+1])  ,  min(dis(p[a],p[b]) , dis(p[a+1],p[b]))  );
    int i,j,k,mid;
    mid=(a+b)>>1;
    double M=min(clo(a,mid),clo(mid,b));
    k=0;
    for(i=a;i<=b;i++)
    {
        if(p[mid].x-p[i].x<=M)
        ans[k++]=p[i];
    }
    sort(ans,ans+k,cmpy);
    for(i=0;i<k;i++)
    for(j=i+1;j<k;j++)
    {
        if(ans[j].y-ans[i].y>=M)
        break;
        M=min(M,dis(ans[i],ans[j]));
    }
    return M;
}

int main()
{
    while(~scanf("%d",&n)&&n)
    {
        for(int i=0;i<n;i++)
        scanf("%lf%lf",&p[i].x,&p[i].y);
        sort(p,p+n,cmpx);
        printf("%.2lf\n",sqrt(clo(0,n-1))/2);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值