Zipper HDU - 1501 (DFS)一个搜索题

Problem Description

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming “tcraete” from “cat” and “tree”:

String A: cat
String B: tree
String C: tcraete

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming “catrtee” from “cat” and “tree”:

String A: cat
String B: tree
String C: catrtee

Finally, notice that it is impossible to form “cttaree” from “cat” and “tree”.

Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

Output

For each data set, print: Data set n: yes if the third string can be formed from the first two, or Data set n: no if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

Sample Input

3
cat tree tcraete
cat tree catrtee
cat tree cttaree

Sample Output

Data set 1: yes
Data set 2: yes
Data set 3: no

题目要求:在不改变a字符串,b字符串顺序的情况下,能否组成字符串c;
解题思路:关键点是a和b两串之和为c串的长度,可以进行搜索,结束条件就是c串的尾字符一定是a或b的尾字符由此可得出一下代码:

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
char a[1010],b[1010];
char v[2020];
int flag,la,lb,lv;
bool book[1010][1010];
void dfs(int x,int y,int z)   //x,y,z分别表示a,b,c串的第x,y,z个位置
{
    if(flag||book[x][y])
        return ;
    if(z==lv)
    {
        flag=1;
        return ;
    }
    book[x][y]=1;
    if(x<la&&a[x]==v[z])   //x,y,z分别表示a、b、c串的第x,y,z个位置
        dfs(x+1,y,z+1);
    if(y<lb&&b[y]==v[z])   //b串的第y个字符跟c串的第z个字符相等
        dfs(x,y+1,z+1);
}
int main()
{
    int T,k=0;
    cin>>T;
    while(T--)
    {
        cin>>a>>b>>v;
        la=strlen(a);
        lb=strlen(b);
        lv=strlen(v);
        memset(book,0,sizeof(book));
        flag=0;
        dfs(0,0,0);
        printf("Data set %d: ",++k);
        if(flag)
            puts("yes");
        else
            puts("no");
    }
    return 0;
}

实践才是检验真理的唯一标准;

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值