HDU1729-Stone Game

题目链接                           Stone Game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 3829    Accepted Submission(s): 1241

 

Problem Description

This game is a two-player game and is played as follows:

1. There are n boxes; each box has its size. The box can hold up to s stones if the size is s.
2. At the beginning of the game, there are some stones in these boxes.
3. The players take turns choosing a box and put a number of stones into the box. The number mustn’t be great than the square of the number of stones before the player adds the stones. For example, the player can add 1 to 9 stones if there are 3 stones in the box. Of course, the total number of stones mustn’t be great than the size of the box.
4.Who can’t add stones any more will loss the game.

Give an Initial state of the game. You are supposed to find whether the first player will win the game if both of the players make the best strategy.

 

Input

The input file contains several test cases.
Each test case begins with an integer N, 0 < N ≤ 50, the number of the boxes.
In the next N line there are two integer si, ci (0 ≤ ci ≤ si ≤ 1,000,000) on each line, as the size of the box is si and there are ci stones in the box.
N = 0 indicates the end of input and should not be processed.

 

Output

For each test case, output the number of the case on the first line, then output “Yes” (without quotes) on the next line if the first player can win the game, otherwise output “No”.

 

Sample Input

3

2 0

3 3

6 2 

2

6  3

6 3

0

 

Sample Output

Case 1:

Yes

Case 2:

No

 

Source

“网新恩普杯”杭州电子科技大学程序设计邀请赛

 

题目意思:首先给你一个n,接下来输入n个boxs的容量和它里面对应有的石子,两人可以把任意石子放入boxs里,石子的来源无限,但是放入的石子不能超过boxs里面已经有的石子的平方,并且不能超过boxs的容量,谁不能再操作谁就输了。

思路:

感觉自己写的思路会跟别人的一样,写的不清楚,所以还请参考大神博客

代码:参考队友的模板§(* ̄▽ ̄*)§,这个代码写的不错,结合大神博客更易懂哦!

#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
int SG(int si, int ci) {
	int q = sqrt((double) si);
	while(q+q*q >= si) q--;//找到刚好使 q+q*q < si && (q+1)+(q+1)*(q+1) >= si 
	if(ci > q)    // 先手获胜 
		return si - ci;
	else //无法判断,递归 
		return SG(q, ci);
}
int main()
{
	int n, si, ci;
	int j = 1;
	while(~scanf("%d", &n) && n) {
		int sum = 0;
		while(n--) {
			scanf("%d %d", &si, &ci);
			sum ^= SG(si, ci);
		}
		printf("Case %d:\n", j++);
		if(sum)//原来这里写反了 很郁闷 
			printf("Yes\n");
		else
			printf("No\n");
	}
} 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值