hdu1729(博弈SG)

地址:http://acm.hdu.edu.cn/showproblem.php?pid=1729

Stone Game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 2317    Accepted Submission(s): 669


Problem Description
This game is a two-player game and is played as follows:

1. There are n boxes; each box has its size. The box can hold up to s stones if the size is s.
2. At the beginning of the game, there are some stones in these boxes.
3. The players take turns choosing a box and put a number of stones into the box. The number mustn’t be great than the square of the number of stones before the player adds the stones. For example, the player can add 1 to 9 stones if there are 3 stones in the box. Of course, the total number of stones mustn’t be great than the size of the box.
4.Who can’t add stones any more will loss the game.

Give an Initial state of the game. You are supposed to find whether the first player will win the game if both of the players make the best strategy.
 

Input
The input file contains several test cases.
Each test case begins with an integer N, 0 < N ≤ 50, the number of the boxes.
In the next N line there are two integer si, ci (0 ≤ ci ≤ si ≤ 1,000,000) on each line, as the size of the box is si and there are ci stones in the box.
N = 0 indicates the end of input and should not be processed.
 

Output
For each test case, output the number of the case on the first line, then output “Yes” (without quotes) on the next line if the first player can win the game, otherwise output “No”.
 

Sample Input
  
  
3 2 0 3 3 6 2 2 6 3 6 3 0
 

Sample Output
  
  
Case 1: Yes Case 2: No
 

题意:有m个盒子,每个盒子最多装si个石头,现已有ci个石头,你每次至多可以装已有石头数目的平方数的石头。不能操作者败,问先手是否获胜。

思路:主要是看这个博客理解的:http://qianmacao.blog.163.com/blog/static/2033971802012343334856/

            对于第i个盒子,存在一个数c使得c*c+c>=si,现在判断该盒子

            若ci>=c则是必胜态,并且必须添加si-ci个石头才会获胜,用SG函数来说对于该堆石子返回值为si-ci;

            若ci<c,那么当ci<c-1并且大于c的c时也是必胜态,所以返回对c处理的函数。

代码:

#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
#define LL __int64
int getnn(int a)
{
    int b=(int)sqrt(a*1.0);
    while(b*(b+1)>=a) b--;
    return b;
}
int dfs(int a,int b)
{
    int c=getnn(b);
    if(a>c) return b-a;
    else return dfs(a,c);
    return 0;
}
int main()
{
    int m,cas=1;
    while(scanf("%d",&m)>0,m)
    {
        int ans=0;
        for(int i=0,a,b;i<m;i++)
        {
            scanf("%d%d",&b,&a);
            ans^=dfs(a,b);
        }
        printf("Case %d:\n",cas++);
        puts(ans?"Yes":"No");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值