POJ-1322 Chocolate(概率DP)

Chocolate
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9279 Accepted: 2417 Special Judge
Description

In 2100, ACM chocolate will be one of the favorite foods in the world.

“Green, orange, brown, red…”, colorful sugar-coated shell maybe is the most attractive feature of ACM chocolate. How many colors have you ever seen? Nowadays, it’s said that the ACM chooses from a palette of twenty-four colors to paint their delicious candy bits.

One day, Sandy played a game on a big package of ACM chocolates which contains five colors (green, orange, brown, red and yellow). Each time he took one chocolate from the package and placed it on the table. If there were two chocolates of the same color on the table, he ate both of them. He found a quite interesting thing that in most of the time there were always 2 or 3 chocolates on the table.

Now, here comes the problem, if there are C colors of ACM chocolates in the package (colors are distributed evenly), after N chocolates are taken from the package, what’s the probability that there is exactly M chocolates on the table? Would you please write a program to figure it out?
Input

The input file for this problem contains several test cases, one per line.

For each case, there are three non-negative integers: C (C <= 100), N and M (N, M <= 1000000).

The input is terminated by a line containing a single zero.
Output

The output should be one real number per line, shows the probability for each case, round to three decimal places.
Sample Input

5 100 2

0
Sample Output

0.625
题意:就是在一堆巧克力中选取n个,每当有两个颜色一样的巧克力就把他们吃了,问,桌面上剩下的巧克力是m个的概率。这是一道概率DP题目。状态转移方程:
dp[i][j]=dp[i-1][j-1](c-(j-1))/(c*1.0)+dp[i-1][j+1](j+1)/(c*1.0);
此题注意,数据量相当大,有两个节省大量时间的减值,一个是若m和n同奇或同偶的,则概率为0
n大于1000的时候,
if(n>1000)
{
n=1000+n%2;
}
似乎用到统计学的知识,反正大于1000,之后的数据量影响不大,相当于1000或者1001;

#include <iostream>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <stdlib.h>

using namespace std;
double dp[1010][105];
int c,n,m;
int main()
{
    while(scanf("%d",&c)!=EOF)
    {   if(c==0)
            break;
        scanf("%d%d",&n,&m);
        if(m>c||m>n||((n%2)!=(m%2)))
        {
            printf("0.000\n");
        }
        else
        {
            if(n>1000)
            {
                n=1000+n%2;
            }
            memset(dp,0,sizeof(dp));
            dp[0][0]=1;
            dp[1][0]=0;
            for(int i=1;i<=n;i++)
            {
                dp[i][0]=dp[i-1][1]*(1)/(c*1.0);
                dp[i][c]=dp[i-1][c-1]*(c-(c-1))/(c*1.0);
                for(int j=1;j<c;j++)
                {
                    dp[i][j]=dp[i-1][j-1]*(c-(j-1))/(c*1.0)+dp[i-1][j+1]*(j+1)/(c*1.0);

                }
            }
            printf("%.3lf\n",dp[n][m]);

        }
    }
    return 0;
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值