ACM: 概率DP 动态规划题 poj 1322

Chocolate

Description

In 2100, ACM chocolate will be one of the favorite foods in the world.

"Green, orange, brown, red...", colorful sugar-coated shell maybe is the most attractive feature of ACM chocolate. How many colors have you ever seen? Nowadays, it's said that the ACM chooses from a palette of twenty-four colors to paint their delicious candy bits.

One day, Sandy played a game on a big package of ACM chocolates which contains five colors (green, orange, brown, red and yellow). Each time he took one chocolate from the package and placed it on the table. If there were two chocolates of the same color on the table, he ate both of them. He found a quite interesting thing that in most of the time there were always 2 or 3 chocolates on the table.

Now, here comes the problem, if there are C colors of ACM chocolates in the package (colors are distributed evenly), after N chocolates are taken from the package, what's the probability that there is exactly M chocolates on the table? Would you please write a program to figure it out?

Input

The input file for this problem contains several test cases, one per line.

For each case, there are three non-negative integers: C (C <= 100), N and M (N, M <= 1000000).

The input is terminated by a line containing a single zero.

Output

The output should be one real number per line, shows the probability for each case, round to three decimal places.

Sample Input

5 100 2

0

Sample Output

0.625 
题意: 一共有c种巧克力, 每种的个数都是一样多并且是足够多, 现在从包里面拿出n次巧克力一次一个,
     当桌面上有2个相同的时候就吃掉, 现在问你在桌面上出现m个巧克力的概率.
解题思路:
    1. 状态dp[i][j]: 前i次操作时, 桌面上出现j个巧克力的概率. (i+j)为奇数是dp[i][j]=0;
    2. 问题:状态方程:dp[i][j] = dp[i-1][j-1]*(c-j+1.0)/c + dp[i-1][j+1]*(j+1.0)/c;
     (原来错误的方程:dp[i][j] = dp[i-1][j-1]*(c-j)/c + dp[i-1][j+1]*j/c;)
      谢谢指出此错误的博客朋友.
                p = (c-j+1.0)/c: 当前抽取出来的概率不相同.
                q = (j+1.0)/c: 下一个抽取出来的概率相同.
           因为这样的结果都是桌面上剩下: j-1个巧克力.
        3. 郁闷的问题: 从网上别人的思考发现, 当抽取次数越来越大的时候, 概率已经是趋于平衡.
代码:
#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
#define MAX 105
int c, n, m;
double dp[MAX*10][MAX];
int main()
{
// freopen("input.txt","r",stdin);
 while(scanf("%d",&c) != EOF)
 {
  if(c == 0) break;
  scanf("%d %d",&n,&m);
  if(m > c || m > n || (m+n)%2 != 0)
  {
   printf("0.000\n");
   continue;
  }
  memset(dp,0,sizeof(dp));
  if(n > 1000) n = 1000+n%2;
  dp[0][0] = 1;
  for(int i = 1; i <= n; ++i)
  {
   for(int j = 0; j <= c; ++j)
   {
    if( (i+j)%2 != 0 ) continue;
    dp[i][j] = dp[i-1][j-1]*(c-j+1.0)/c + dp[i-1][j+1]*(j+1.0)/c;
   }
  }
  printf("%.3lf\n",dp[n][m]);
 }
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值