PAT 甲级 1020 Tree Traversals (二叉树遍历)

1020. Tree Traversals (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:

4 1 6 3 5 7 2


根据后续遍历和中序遍历,求二叉树

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>
#include <queue>

using namespace std;
typedef struct Tree
{
    int data;
    Tree *lchild;
    Tree *rchild;
}a[40];
int post[40];
int in[40];
int n;
int ans[40];
void dfs(int l1,int r1,int l2,int r2,Tree* &root)
{
  root=new Tree();
    int i;
    for( i=l1;i<=r1;i++)
        if(in[i]==post[r2])
            break;
    root->data=post[r2];
    if(i==l1)
        root->lchild=NULL;
    else
        dfs(l1,i-1,l2,l2+i-l1-1,root->lchild);
    if(i==r1)
        root->rchild=NULL;
    else
        dfs(i+1,r1,r2-(r1-i),r2-1,root->rchild);
}
int cnt;
void bfs(Tree *tree)
{
  queue<Tree*> q;
  q.push(tree);
  while(!q.empty())
  {
    Tree *root=q.front();
    q.pop();
    ans[cnt++]=root->data;
    if(root->lchild!=NULL)
      q.push(root->lchild);
    if(root->rchild!=NULL)
      q.push(root->rchild);
  }
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&post[i]);
        for(int i=1;i<=n;i++)
            scanf("%d",&in[i]);
        Tree *tree;
        dfs(1,n,1,n,tree);
    cnt=0;
    bfs(tree);
    for(int i=0;i<cnt;i++)
    {
      if(i==cnt-1)
      printf("%d\n",ans[i]);
      else
        printf("%d ",ans[i]);
    }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值