1020 Tree Traversals

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

题意:知道后序遍历树的序列、中序遍历树的序列,求层次遍历树的序列 

思路:根据后序遍历的序列和中序遍历的序列重建树,然后再利用队列对树进行层次遍历

学习过程可参考LeetCode 树这一章节

/*
postorder sequence and the third line gives the inorder sequence.
Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2
*/
#include<iostream>
#include<vector>
#include<queue>
using namespace std;
struct TreeNode
{
	int val;
	TreeNode *left,*right;
	TreeNode(int x):val(x),left(NULL),right(NULL){} 
};
int N;
int post[31];
int in[31];
TreeNode* build(int pleft,int pright,int ileft,int iright)
{
	if(pleft>pright||ileft>iright) return NULL;
	TreeNode *cur=new TreeNode(post[pright]);
	int i=0;
	for(i=ileft;i<=iright;i++)
	{
		if(cur->val==in[i]) break;
	}
	cur->left=build(pleft,pleft+i-ileft-1,ileft,i-1);
	cur->right=build(pleft+i-ileft,pright-1,i+1,iright);
	return cur;
}
void PrintTreeNode(TreeNode *root)
{   queue<TreeNode*> q;
	if(root==NULL) return;
	printf("%d",root->val);
	if(root->left!=NULL)
	q.push(root->left);
	if(root->right!=NULL)
	q.push(root->right);
	while(!q.empty())
	{   int s=q.size();
		for(int i=0;i<s;i++)
		{
			TreeNode *t=q.front();
			q.pop();
			printf(" %d",t->val);
			if(t->left!=NULL)
			q.push(t->left);
			if(t->right!=NULL)
			q.push(t->right);
		}
	}
}
int main()
{
   scanf("%d",&N);
   for(int i=0;i<N;i++)
   {
   	 scanf("%d",&post[i]);
   }
   for(int i=0;i<N;i++)
   {
   	 scanf("%d",&in[i]);
   }
   TreeNode *tree=build(0,N-1,0,N-1);
   PrintTreeNode(tree);
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值