查分约束POJ3169Layout解题报告

Layout
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8739 Accepted: 4202
Description
Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.
Input
Line 1: Three space-separated integers: N, ML, and MD.

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.
Output
Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.
Sample Input
4 2 1
1 3 10
2 4 20
2 3 3
Sample Output
27
Hint
Explanation of the sample:

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.
Source
USACO 2005 December Gold
最短路径的应用,查分约束。将题目中的不等式转化成求最短路的松弛不等式,但还要将每两个点相连。而且要判断负环,所以用Bellman-ford算法,加堆栈或队列优化。

//808K  141MS(用模板的栈,125ms)
//队列优化47ms!!!
#include<iostream>
#include<cstdio>
using namespace std;
const int nMax = 1005;
const int eMax = 21005;
const int inf = 0xffffff;
struct node{
    int v, w, next;
}edge[eMax];
int n, k, edgeHead[nMax], dis[nMax], sum[nMax];
int stack[nMax];
bool vis[nMax];
void add_edge(int u, int v, int w){
    edge[k].v = v;
    edge[k].w = w;
    edge[k].next = edgeHead[u];
    edgeHead[u] = k ++;
}
bool spfa(){
    for(int i = 2; i <= n; i ++) dis[i] = inf;
    dis[1] = 0;
    int top = 0;     //  堆栈实现spfa。
    stack[++ top] = 1;
    vis[1] = true;
    while(top){
        int u = stack[top --];
        vis[u] = false;
        for(int p = edgeHead[u]; p != 0; p = edge[p].next){
            int v = edge[p].v;
            if(dis[v] > dis[u] + edge[p].w){
                dis[v] = dis[u] + edge[p].w;
                if(!vis[v]){
                    vis[v] = true;
                    stack[++ top] = v;
                    if(++ sum[v] > n)    //  有一个点进栈超过n次,则说明有负环。
                        return true;
                }
            }
        }
    }
    return false;
}
int main(){
    freopen("input.txt","r",stdin);
    freopen("output.txt","w",stdout);
    int ml, md;
    scanf("%d%d%d", &n, &ml, &md);
    k = 1;
    int u, v, w;
    while(ml --){
        scanf("%d%d%d", &u, &v, &w);
        add_edge(u, v, w);//dis[v]<=dis[u]+w;
    }
    while(md--){
        scanf("%d%d%d", &v, &u, &w);
        add_edge(u, v, -w);//dis[u]<=dis[v]-w;
    }
    for(int i = 1; i < n; i ++)//将每两个点相连
        add_edge(i + 1, i, 0);
    if(spfa())  printf("-1\n");               //  有负环存在,方程组无解。
    else if(dis[n] == inf)  printf("-2\n");   //  距离为inf。
    else printf("%d\n", dis[n]);              //  有解
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值