Apple开发证书和发布证书不受信任问题

2021-3-5

 

在iOS开发中,需要在开发者后台申请开发证书和发布证书,并在开发设备上进行安装。

 

问题:

证书安装完毕后,钥匙串中开发证书和发布证书均提示:

证书不受信任

 

这是一个常规问题,出现此错误说明开发设备中没有安装Apple全球开发者关系认证媒介中间证书AppleWWDRCA,或者已安装的WWDRCA失效了。

 

解决办法:

重新下载Apple Worldwide Developer Relations 认证媒介中间证书,并安装之:

https://developer.apple.com/certificationauthority/AppleWWDRCA.cer

 

以往安装新的WWDRCA后,该问题就解决了,然而这次失算了,开发证书和发布证书依然提示:证书不受信任。

 

正宗的解决办法:

目前的Apple全球开发者关系认证中间证书WWDRCA(也就是我们上面下载的那个)将于2023年2月7日到期。Apple发布了新的WWDRCA,更新后的证书过期时间为2030年2月20日,新证书将用于签署2021年1月28日后为苹果开发者项目颁发的新软件签名证书。

因此,我们需要下载并安装新的WWDRCA:

https://www.apple.com/certificateauthority/AppleWWDRCAG3.cer

 

Apple证书列表:

https://www.apple.com/certificateauthority/

红框中的便是Apple全球开发者关系认证中间证书WWDRCA。

  • 6
    点赞
  • 4
    收藏
  • 打赏
    打赏
  • 5
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:大白 设计师:CSDN官方博客 返回首页
评论 5

打赏作者

Dancen

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值