这个作业属于那个课程 | C语言程序设计II |
---|---|
这个作业要求在哪里 | https://edu.cnblogs.com/campus/zswxy/computer-scienceclass1-2018/homework/3238 |
我在这个课程的目标是 | 学好;链表 |
这个作业在那个具体方面帮助我实现目标 | 链表 |
参考文献 | C语言程序设计II,C primer plus |
本题要求实现一个函数,用于计算有n个元素的指针数组s中最长的字符串的长度。
函数接口定义:
int max_len( char *s[], int n );
其中n
个字符串存储在s[]
中,函数max_len
应返回其中最长字符串的长度。
裁判测试程序样例:
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define MAXN 10
#define MAXS 20
int max_len( char *s[], int n );
int main()
{
int i, n;
char *string[MAXN] = {NULL};
scanf("%d", &n);
for(i = 0; i < n; i++) {
string[i] = (char *)malloc(sizeof(char)*MAXS);
scanf("%s", string[i]);
}
printf("%d\n", max_len(string, n));
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
4
blue
yellow
red
green
输出样例:
6
实验代码:
int max_len( char *s[], int n )
{
int max=0;
int i;
for(i=0;i<n;i++){
if(strlen(s[max])<strlen(s[i]))
{
max=i;
}
}
return strlen(s[max]);
}
流程图
运行结果
6-2 统计专业人数 (15 分)
本题要求实现一个函数,统计学生学号链表中专业为计算机的学生人数。链表结点定义如下:
struct ListNode {
char code[8];
struct ListNode *next;
};
这里学生的学号共7位数字,其中第2、3位是专业编号。计算机专业的编号为02。
函数接口定义:
int countcs( struct ListNode *head );
其中head
是用户传入的学生学号链表的头指针;函数countcs
统计并返回head
链表中专业为计算机的学生人数。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct ListNode {
char code[8];
struct ListNode *next;
};
struct ListNode *createlist(); /*裁判实现,细节不表*/
int countcs( struct ListNode *head );
int main()
{
struct ListNode *head;
head = createlist();
printf("%d\n", countcs(head));
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
1021202
2022310
8102134
1030912
3110203
4021205
#
输出样例:
3
实验代码
int countcs( struct ListNode *head )
{
int num = 0;
while(head!= NULL)
{
if(head->code[1] == '0' && head->code[2] == '2')
num++;
head = head->next;
}
return num;
}
流程图
运算结果
6-3 删除单链表偶数节点 (20 分)
本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中偶数值的结点删除。链表结点定义如下:
struct ListNode {
int data;
struct ListNode *next;
};
函数接口定义:
struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
函数createlist
从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−时表示输入结束,函数应返回指向单链表头结点的指针。
函数deleteeven
将单链表head
中偶数值的结点删除,返回结果链表的头指针。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
struct ListNode {
int data;
struct ListNode *next;
};
struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
void printlist( struct ListNode *head )
{
struct ListNode *p = head;
while (p) {
printf("%d ", p->data);
p = p->next;
}
printf("\n");
}
int main()
{
struct ListNode *head;
head = createlist();
head = deleteeven(head);
printlist(head);
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
1 2 2 3 4 5 6 7 -1
输出样例:
1 3 5 7
实验代码
struct ListNode *createlist()
{
int x;
struct ListNode *head,*tail,*p;
head=(struct ListNode*)malloc(sizeof(struct ListNode));
head->next=NULL;
tail=head;
while(1)
{
p=(struct ListNode*)malloc(sizeof(struct ListNode));
p->next=NULL;
scanf("%d",&x);
if(x==-1)
break;
p->data=x;
p->next=NULL;
tail->next=p;
tail=p;
}
return head;
}
struct ListNode *deleteeven( struct ListNode *head )
{
struct ListNode *p1,*p2;
int flag;
p1=head;
p2=p1->next;
while(p1->next)
{
flag=0;
if(p2->data%2==0)
{
p1->next=p2->next;
p2=p2->next;
flag=1;
}
if(flag==0)
{
p1=p1->next;
p2=p1->next;
}
}
return head->next;
}
因题超出 能力水平 此代码借鉴 CSDN poetVVVhttps://blog.csdn.net/Lzhaowei/article/details/84654496
三,预习作业
从第十三周开始,将进入课程设计阶段,请在本次作业中给出:
1.所在小组想要开发的项目的名称和目标:
2.项目主体功能的描述:
3.现阶段已做的准备工作:
有创意了,有目标了,有人员了,学习基础知识,逐渐提升。
4.小组成员名单和进度安排:(课程设计阶段:13-17周)
雷思骞 陈舒遥 曹耀隆
安排未定,进度暂无。
四、结对编程总结
没有进行编程 只是游戏入门 皮毛教学
五,学习进度统计
学习进度条
周/日期 | 这周所花的时间 | 代码行数 | 学到的知识点简介 | 目前比较迷惑的问题 |
---|---|---|---|---|
3/2-3/8 | 8h | 100 | 文件入门 | 数组串,指针 |
3/9-3/15 | 10h | 110 | 文件与数组 | 双for循环的流程图 |
3/16-3/22 | 3h | 150 | 数组排序法 | 字符串使用 |
3/23-3/29 | 5h | 200 | 字符串的定义及其使用 | 指针 |
3/30-4/5 | 2h | 100 | 指针变量的定义, | 指针 |
4/6-4/12 | 4h | 100 | 数组名 | 指针函数 |
4/13-4/19 | 5h | 50 | 指针数组 | 结构体 |
4/20-4/26 | 10h | 40 | 递归 | 递归 |
4/26-5/3 | 10h | 50 | 汉诺塔 | 汉诺塔 |