Given the relations of all the activities of a project, you are supposed to find the earliest completion time of the project.
Input Specification:
Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of activity check points (hence it is assumed that the check points are numbered from 0 to N−1), and M, the number of activities. Then M lines follow, each gives the description of an activity. For the i
-th activity, three non-negative numbers are given: S[i]
, E[i]
, and L[i]
, where S[i]
is the index of the starting check point, E[i]
of the ending check point, and L[i]
the lasting time of the activity. The numbers in a line are separated by a space.
Output Specification:
For each test case, if the scheduling is possible, print in a line its earliest completion time; or simply output "Impossible".
Sample Input 1:
9 12
0 1 6
0 2 4
0 3 5
1 4 1
2 4 1
3 5 2
5 4 0
4 6 9
4 7 7
5 7 4
6 8 2
7 8 4
结尾无空行
Sample Output 1:
18
结尾无空行
Sample Input 2:
4 5
0 1 1
0 2 2
2 1 3
1 3 4
3 2 5
Sample Output 2:
Impossible
#include <iostream>
#include <queue>
#include <algorithm>
#include <cmath>
using namespace std;
const int MAXN = 110;
int net[MAXN][MAXN],in[MAXN],t[MAXN];
int main()
{
int V,E,t1,t2,w,cnt = 0,Max = 0;
scanf("%d %d",&V,&E);
for(int i = 0;i < E;i++){//读入数据
scanf("%d %d %d",&t1,&t2,&w);
net[t1][t2] = w;
}
queue<int> q;
for(int i = 0;i < V;i++){
for(int j = 0;j < V;j++){
if(net[j][i] > 0)
in[i]++;
}
if(in[i] == 0){
q.push(i);
cnt++;
}
}
q.size();
while(!q.empty()){
int temp = q.front();
q.pop();
for(int i = 0;i < V;i++){
if(net[temp][i] > 0){
in[i]--;
if(t[i] < t[temp] + net[temp][i]){
t[i] = t[temp] + net[temp][i];
if(t[i] > Max) Max = t[i];
}
if(in[i] == 0){
q.push(i);
cnt++;
}
}
}
}
if(cnt == V) printf("%d",Max);
else printf("Impossible");
return 0;
}