poj 2782 Bin Packing (贪心+二分)

F - 贪心+ 二分
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu
 

Description

 

A set of n<tex2html_verbatim_mark> 1-dimensional items have to be packed in identical bins. All bins have exactly the same length l<tex2html_verbatim_mark> and each item i<tex2html_verbatim_mark> has length li$ \le$l<tex2html_verbatim_mark> . We look for a minimal number of bins q<tex2html_verbatim_mark> such that

 

  • each bin contains at most 2 items,
  • each item is packed in one of the q<tex2html_verbatim_mark> bins,
  • the sum of the lengths of the items packed in a bin does not exceed l<tex2html_verbatim_mark> .

You are requested, given the integer values n<tex2html_verbatim_mark> , l<tex2html_verbatim_mark> , l1<tex2html_verbatim_mark> , ..., ln<tex2html_verbatim_mark> , to compute the optimal number of bins q<tex2html_verbatim_mark> .

 

Input 

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

 

 


The first line of the input file contains the number of items n<tex2html_verbatim_mark>(1$ \le$n$ \le$105)<tex2html_verbatim_mark> . The second line contains one integer that corresponds to the bin length l$ \le$10000<tex2html_verbatim_mark> . We then have n<tex2html_verbatim_mark> lines containing one integer value that represents the length of the items.

 

Output 

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

 

 


For each input file, your program has to write the minimal number of bins required to pack all items.

 

Sample Input 

 

1

10
80
70
15
30
35
10
80
20
35
10
30

 

Sample Output 

 

6

 

 


Note: The sample instance and an optimal solution is shown in the figure below. Items are numbered from 1 to 10 according to the input order.

 

\epsfbox{p3503.eps}
 
使用贪心,先模拟贪心过程:给出一个桶,那么这个桶能装两个就两个
具体实现:把数组从大到小排序,然后使用两个变,一个在左,一个在右,首先以左边为据,在左边尽量找一个和它放在一个桶里,如果成功就有i++和j--,直到i和j相遇,跳出循环,统计这时已拿出的桶的数量,即为装进去成功的桶的数量
 
 
 
#include<iostream>
using namespace std;
#include<cstdio>
#include<cstring>
#include<algorithm>
int a[100010];
int cmp(int x, int y)
{
    return x>y;
}
int main()
{
    int n,i,l,t;
    cin>>t;
    while(t--)
    {
        cin>>n>>l;
        for(i = 0; i < n; i++)
            cin>>a[i];
        sort(a,a+n,cmp);
        int k=0,j=n-1;
        for(i=0; i<n; i++)
        {
            if(i>j)break;
            k++;
            if(i<j&&a[i]+a[j]<=l)
            {
                j--;
            }
        }
        printf("%d\n",k);
        if(t)cout<<endl;
    }
}

 

 

转载于:https://www.cnblogs.com/hfc-xx/p/4707998.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值