poj 3169差分约束+spfa

Layout
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10124 Accepted: 4873
Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.
Input

Line 1: Three space-separated integers: N, ML, and MD.

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.
Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.
Sample Input

4 2 1
1 3 10
2 4 20
2 3 3
Sample Output

27
Hint

Explanation of the sample:

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

由题目可得条件:
d[i]<=d[i+1]+0;
d[a]<=d[b]-d;//加负权边
d[b]<=d[a]+d;
看到这个我们应当想到:最短路!
由于有负权边,所以用spfa;(队列优化)

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <vector>
#define inf 0x3f3f3f3f
using namespace std;
int N ,ML,MD;
struct edge
{
    int to,cost;
    edge(int a=0,int b=0):to(a),cost(b) {}
};
vector<edge> G[1009];//邻接表
int vis[1009];
int num[1009],d[1009];
void spfa()
{
    memset(vis,0,sizeof vis);
    memset(d,inf,sizeof d);
    memset(num,0,sizeof num);
    d[1]=0,vis[1]=1,num[1]=1;
    queue<int> q;
    q.push(1);
    while(!q.empty())
    {
        int t=q.front();
        q.pop();
        vis[t]=0;//标记是否在队中,出队置零,入队置一
        for(int i=0; i<G[t].size(); i++)
        {
            int v=G[t][i].to,w=G[t][i].cost;
            if(d[v]>d[t]+w)
            {
                d[v]=d[t]+w;

                if(!vis[v])
                {
                    if(num[v]>N)//判断是否有负环,每个点的更新次数不会超过N次
                    {
                        puts("-1");
                        return;
                    }
                    q.push(v);
                    vis[v]=1;
                    num[v]++;
                }
            }
        }
    }
    if(d[N]==inf)//判断是否可以无限大
        puts("-2");
    else printf("%d\n",d[N]);
}
int main()
{
    scanf("%d%d%d",&N,&ML,&MD);
    int a,b,d;
    for(int i=0; i<ML; i++)
    {
        scanf("%d%d%d",&a,&b,&d);
        G[a].push_back(edge(b,d));//d[b]<=d[a]+d;
    }
    for(int i=0; i<MD; i++)
    {
        scanf("%d%d%d",&a,&b,&d);//d[a]<=d[b]-d;
        G[b].push_back(edge(a,-d));
    }
    for(int i=1; i<N; i++)
    {
        G[i+1].push_back(edge(i,0));//隐含条件:d[i+1]<=d[i]+0;
    }
    spfa();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值