Layout(差束约分系统)

Description
Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.
Input
Line 1: Three space-separated integers: N, ML, and MD.

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.
Output
Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.
Sample Input
4 2 1
1 3 10
2 4 20
2 3 3
Sample Output
27
Hint
Explanation of the sample:

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

前ML个条件是a和b最多差x,后面MD个条件是a和b至多差x,如果没有解输出-1,如果可以无穷远,输出-2,之外输出1到n的最远距离。

d[b] - d[a] <= x
d[b] - d[a] >= x
只要把第二个式子加一个负号就好了,在图里面表示就是反向边,用判负环的spfa跑一遍,最后检查是否有点进入n+次队列,如果有,肯定是没有解了(死循环,可以脑补想一下),如果没有,再看看d[n]是否是无穷大,再根据情况输出。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<vector>
#include<algorithm>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<vector>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int maxn = 1005;
int head[1005],n,ml,md;
int ans[1005];
ll d[1005];
bool leap[1005];
struct Node
{
    int u,v,next;
    ll w;
}node[20050];
void add_edge(int u,int v,ll w,int tot)
{
    node[tot].u = u;node[tot].v = v;
    node[tot].w = w;
    node[tot].next = head[u];
    head[u] = tot;
}
void spfa()
{
    for(int i = 1;i <= n;i++)leap[i] = false;
    for(int i = 1;i <= n;i++)d[i] = inf;
    for(int i = 1;i <= n;i++)ans[i] = 0;
    d[1] = 0;leap[1] = true;ans[1] = 1;
    queue<int>p;
    p.push(1);
    while(p.size())
    {
        int u = p.front();p.pop();
        leap[u] = false;
        for(int i = head[u];i != -1;i = node[i].next)
        {
            int v = node[i].v;
            if(d[v] > d[u] + node[i].w)
            {
                d[v] = d[u] + node[i].w;
                if(!leap[v])
                {
                    ans[v]++;
                    if(ans[v] <= n)
                    {
                        leap[v] = true;p.push(v);
                    }
                }
            }
        }
    }
}
bool check()
{
    for(int i = 1;i <= n;i++)
    {
        if(ans[i] > n)
            return false;
    }
    return true;
}
int main()
{
    #ifdef LOCAL
    freopen("C:\\Users\\巍巍\\Desktop\\in.txt","r",stdin);
    //freopen("C:\\Users\\巍巍\\Desktop\\out.txt","w",stdout);
    #endif // LOCAL
    while(scanf("%d%d%d",&n,&ml,&md) != EOF)
    {
        memset(head,-1,sizeof(head));
        int cnt = 1;
        for(int i = 1;i <= ml;i++)
        {
            int u,v;ll w;
            scanf("%d%d%lld",&u,&v,&w);
            add_edge(u,v,w,cnt++);
        }
        for(int i = 1;i <= md;i++)
        {
            int u,v;ll w;
            scanf("%d%d%lld",&u,&v,&w);
            add_edge(v,u,-w,cnt++);
        }
        spfa();
        if(check())
        {
            if(d[n] == inf)
                printf("-2\n");
            else
                printf("%d\n",d[n]);
        }
        else
            printf("-1\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值