ZOJ 3609 Modular Inverse

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3609


题面:


Modular Inverse

Time Limit: 2 Seconds       Memory Limit: 65536 KB

The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1x (mod m). This is equivalent to ax≡1 (mod m).

Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.

Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output

For each test case, output the smallest positive x. If such x doesn't exist, output "Not Exist".

Sample Input
3
3 11
4 12
5 13
Sample Output
4
Not Exist
8


解题:

    乍一看,应该是中国剩余定理,还是什么线性同余方程,不过当初学这块没学好,仔细一看可以水过,等复习后,再来补充其他解法。

思路:

    因为(a*x)%m==1%m,可以写作(a*(x'+n*m))%m==1%m,当x的值超过m时,其实已经重复了,而m的范围在0到1000,所以直接暴就好了。

    比较坑的是,写的时候,直接就把右边写作1了,没考虑到m=1的情况。因此,细节还是相当重要的,提交前,需要仔细检查一下边界数据。


代码:

#include <iostream>
#include <algorithm>
#include <string>
#include <iomanip>
#include <cstdio>
#include <cstring>
using namespace std;

int main()
{
    int t,a,m,x;
    bool flag;
    scanf("%d",&t);
    while(t--)
    {
    	scanf("%d%d",&a,&m);
    	if(m==1)
		{
		  printf("1\n");
		  continue;
		}
        flag=false;
        for(int i=1;i<=m;i++)
        {
           if((a*i)%m==1)
           {
             flag=true;
             printf("%d\n",i);
             break;
           }
        }
        if(!flag)printf("Not Exist\n");
    }
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值