BestCoder Round 38-1001 Four Inages Strategy

题目链接:http://bestcoder.hdu.edu.cn/contests/contest_showproblem.php?cid=577&pid=1001


题面:

Four Inages Strategy

 
 Accepts: 272
 
 Submissions: 1374
 Time Limit: 2000/1000 MS (Java/Others)
 
 Memory Limit: 65536/65536 K (Java/Others)
Problem Description

Young F found a secret record which inherited from ancient times in ancestral home by accident, which named "Four Inages Strategy". He couldn't restrain inner exciting, open the record, and read it carefully. " Place four magic stones at four points as array element in space, if four magic stones form a square, then strategy activates, destroying enemy around". Young F traveled to all corners of the country, and have collected four magic stones finally. He placed four magic stones at four points, but didn't know whether strategy could active successfully. So, could you help him?

Input

Multiple test cases, the first line contains an integer  T (no more than  10000 ), indicating the number of cases. Each test case contains twelve integers  x1,y1,z1,x2,y2,z2,x3,y3,z3,x4,y4,z4,|x|,|y|,|z|100000 ,representing coordinate of four points. Any pair of points are distinct.

Output

For each case, the output should occupies exactly one line. The output format is Case # x ans , here  x  is the data number begins at  1 , if your answer is yes, ans  is Yes, otherwise  ans  is No.

Sample Input
2
0 0 0 0 1 0 1 0 0 1 1 0
1 1 1 2 2 2 3 3 3 4 4 4
Sample Output
Case #1: Yes
Case #2: No

题意:

  给定空间四个点,判断四个点是否组成了一个正方形。

解法:

    比较笨的考虑了四个点的全部位置分布,不过比较安全。先判断对角线相等, 邻边相等,再加邻边垂直。

代码:

#include <iostream>
#include <string>
#include <cstring>
int store[26],tmp[26];
using namespace std;
int squared_dis(int a,int b,int c,int d,int e,int f)
{
    return (a-d)*(a-d)+(b-e)*(b-e)+(c-f)*(c-f); 
}
int main()
{
    int n,x1,y1,z1,x2,y2,z2,x3,y3,z3,x4,y4,z4;
    cin>>n;
    for(int i=1;i<=n;i++)
    {
        bool flag=false;
        cin>>x1>>y1>>z1>>x2>>y2>>z2>>x3>>y3>>z3>>x4>>y4>>z4;
        if(squared_dis(x1,y1,z1,x3,y3,z3)==squared_dis(x2,y2,z2,x4,y4,z4))
        {
            if(squared_dis(x2,y2,z2,x3,y3,z3)==squared_dis(x1,y1,z1,x2,y2,z2))
            {
                if((x4-x1)*(x2-x1)+(y4-y1)*(y2-y1)+(z4-z1)*(z2-z1)==0)
                flag=true;
            }
        }
        if(squared_dis(x1,y1,z1,x2,y2,z2)==squared_dis(x3,y3,z3,x4,y4,z4))
        {
            if(squared_dis(x2,y2,z2,x3,y3,z3)==squared_dis(x1,y1,z1,x3,y3,z3))
            {
                if((x4-x1)*(x3-x1)+(y4-y1)*(y3-y1)+(z4-z1)*(z3-z1)==0)
                flag=true;
            }
        }
        if(squared_dis(x1,y1,z1,x4,y4,z4)==squared_dis(x2,y2,z2,x3,y3,z3))
        {
            if(squared_dis(x2,y2,z2,x1,y1,z1)==squared_dis(x1,y1,z1,x3,y3,z3))
            {
                if((x3-x1)*(x2-x1)+(y3-y1)*(y2-y1)+(z3-z1)*(z2-z1)==0)
                flag=true;
            }
        }
        cout<<"Case #"<<i<<": ";
        if(flag)cout<<"Yes\n";
        else cout<<"No\n";
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值