HDU 5224 Tom and paper(BestCoder Round #40)

题目链接:Tom and paper


题面:

Tom and paper

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 679    Accepted Submission(s): 432


Problem Description
There is a piece of paper in front of Tom, its length and width are integer. Tom knows the area of this paper, he wants to know the minimum perimeter of this paper.
 

Input
In the first line, there is an integer T indicates the number of test cases. In the next T lines, there is only one integer n in every line, indicates the area of paper.
T10,n109
 

Output
For each case, output a integer, indicates the answer.
 

Sample Input
  
  
3 2 7 12
 

Sample Output
  
  
6 16 14
 

Source
 

解题:

若周长固定,取半值附近的值,面积最大。反之,取平方根附近,周长最长。


代码:

#include <iostream>
#include <cmath>
using namespace std;

int main()
{
    int t,n,root;
    cin>>t;
    while(t--)
    {
      cin>>n;
      root=sqrt(1.0*n);
      for(int i=root;;i--)
      {
      	if(n%i==0)
      	{
	      cout<<2*(i+n/i)<<endl;  	
	      break;
        }
      }
    }
    return 0;
}
 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值