HDU 5224 Tom and paper

61 篇文章 0 订阅
Problem Description
There is a piece of paper in front of Tom, its length and width are integer. Tom knows the area of this paper, he wants to know the minimum perimeter of this paper.
 

Input
In the first line, there is an integer T indicates the number of test cases. In the next T lines, there is only one integer n in every line, indicates the area of paper.
T10,n109
 

Output
For each case, output a integer, indicates the answer.
 

Sample Input
  
  
3 2 7 12
 

Sample Output
  
  
6 16

14

直接暴力判断

#include<cstdio>
#include<cmath>
#include<queue>
#include<map>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int T, n;

int main()
{
    scanf("%d", &T);
    while (T--)
    {
        scanf("%d", &n);
        int k = sqrt(1.0*n), ans = 0x7FFFFFFF;
        for (int i = 1; i <= k; i++)
            if (n%i == 0) ans = min(ans, 2 * (i + n / i));
        printf("%d\n", ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值