HDU 5228 ZCC loves straight flush( BestCoder Round #41)

题目链接:ZCC loves straight flush


题面:

ZCC loves straight flush

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 827    Accepted Submission(s): 340


Problem Description
After losing all his chips when playing Texas Hold'em with Fsygd on the way to ZJOI2015, ZCC has just learned a black technology. Now ZCC is able to change all cards as he wants during the game. ZCC wants to get a Straight Flush by changing as few cards as possible.

We call a five-card hand a Straight Flush when all five cards are consecutive and of the same suit. You are given a five-card hand. Please tell ZCC how many cards must be changed so as to get a Straight Flush.
  
Cards are represented by a letter('A', 'B', 'C', 'D') which denotes the suit and a number('1', '2', , '13') which denotes the rank.
  
Note that number '1' represents ace which is the largest actually. "1 2 3 4 5" and "10 11 12 13 1" are both considered to be consecutive while "11 12 13 1 2" is not.
 

Input
First line contains a single integer T(T=1000) which denotes the number of test cases.
For each test case, there are five short strings which denote the cards in a single line. It's guaranteed that all five cards are different.
 

Output
For each test case, output a single line which is the answer.
 

Sample Input
  
  
3 A1 A2 A3 A4 A5 A1 A2 A3 A4 C5 A9 A10 C11 C12 C13
 

Sample Output
  
  
0 1 2
 

Source

解题:

注意顺子只能连到A。


代码:

#include <iostream>
#include <cmath>
#include <cstring>
using namespace std;
bool status[4][15];
int main()
{
    int t,n,root;
    cin>>t;
    char c;
    int tmp,cnt,maxx;
    while(t--)
    {
       memset(status,0,sizeof(status));
       for(int i=0;i<5;i++)
       {
            cin>>c>>tmp;
            status[c-'A'][tmp]=1;
             if(tmp==1)status[c-'A'][14]=1;
       }
       maxx=0;
       for(int i=0;i<4;i++)
       {
            for(int j=1;j<=10;j++)
            {
                cnt=0;
            if(status[i][j])cnt++;
              if(status[i][j+1])cnt++;
              if(status[i][j+2])cnt++;
              if(status[i][j+3])cnt++;
              if(status[i][j+4])cnt++;
              if(cnt>maxx)
                maxx=cnt;
         }
       }
       cout<<5-maxx<<endl;
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值