HDU 5301 Buildings(思维)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5301


题面:

Buildings

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1421    Accepted Submission(s): 400


Problem Description
Your current task is to make a ground plan for a residential building located in HZXJHS. So you must determine a way to split the floor building with walls to make apartments in the shape of a rectangle. Each built wall must be paralled to the building's sides.

The floor is represented in the ground plan as a large rectangle with dimensions n×m , where each apartment is a smaller rectangle with dimensions a×b located inside. For each apartment, its dimensions can be different from each other. The number a and b must be integers.

Additionally, the apartments must completely cover the floor without one 1×1 square located on (x,y) . The apartments must not intersect, but they can touch.

For this example, this is a sample of n=2,m=3,x=2,y=2 .



To prevent darkness indoors, the apartments must have windows. Therefore, each apartment must share its at least one side with the edge of the rectangle representing the floor so it is possible to place a window.

Your boss XXY wants to minimize the maximum areas of all apartments, now it's your turn to tell him the answer.
 

Input
There are at most 10000 testcases.
For each testcase, only four space-separated integers, n,m,x,y(1n,m108,n×m>1,1xn,1ym) .
 

Output
For each testcase, print only one interger, representing the answer.
 

Sample Input
  
  
2 3 2 2 3 3 1 1
 

Sample Output
  
  
1 2
Hint
Case 1 :
You can split the floor into five 1×1 apartments. The answer is 1. Case 2:
You can split the floor into three 2×1 apartments and two 1×1 apartments. The answer is 2.
If you want to split the floor into eight 1×1 apartments, it will be unacceptable because the apartment located on (2,2) can't have windows.
 

Source
 


解题:

    因为方格肯定是1*k的,这样才能让面积最小,一开始,看时限,以为是二分答案。但发现若没有坏点,那么答案就是ans=(min(n,m)+1)/2。但有坏点,会出现两种特殊情况。

1.n等于m,且n为奇数,同时坏点在中心点位置,那么答案就为ans-1;

2.(假设n>m)坏点所在的位置,形成的面向4条边框的距离中,总长为m-1的两条中的一条大于ans,且该条边所在位置,不能由上或下覆盖,那么就取三个方向上离该点(那条无法覆盖的边上离坏点最近的那个点)最近的距离为答案。

3.其余情况,答案都为ans不变。


总结:

    其实,比赛的时候,以上两种特殊情况,都已经找到了,但是,思路太乱,造成不能理性得分析问题。这种问题,应该有条理地进行分析,讨论。想好了再去动手写。


代码:

#include <iostream>
#include <cmath>
using namespace std;
int max(int a,int b)
{
    return a>b?a:b;
}
int min(int a,int b)
{
    return a<b?a:b;
}
int main()
{
    int n,m,x,y,ans;
    while(cin>>n>>m>>x>>y)
    {
      ans=(min(n,m)+1)/2;
      if(n==m)
      {
        if(n%2)
        {
            if(x==(n+1)/2&&y==(m+1)/2)
                ans--;
        }
      }
      else
      {
          int le,ri,up,dw;
          if(n<m)
          {
             swap(n,m);
             swap(x,y);
          }
          le=y;
          ri=m-y+1;
          up=x;
          dw=n-x+1;
          if(m%2)
          {
              if(abs(le-ans)>1)
              {
                  if(up>ans&&dw>ans)
                  {
                      ans=max(le-1,ri-1);
                      ans=min(ans,up);
                      ans=min(ans,dw);
                  }
              }
          }
          else
          {
              if(!(le==ans||le==ans+1))
              {
                  if(up>ans&&dw>ans)
                  {
                      ans=max(le-1,ri-1);
                      ans=min(ans,up);
                      ans=min(ans,dw);
                  }
              }
          }
      }
      cout<<ans<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值