PAT-PAT (Advanced Level) Practise A+B and C (64bit) (20) 【二星级】

博客介绍了PAT中的1065题,即在[-2^63, 2^63]范围内判断A+B是否大于C。通过分析避免数值计算溢出,提出将整数分为除10部分和模10部分分别计算的方法,并给出了解题代码。" 7101498,225506,WPF处理控件滚动条事件技巧,"['WPF', 'UI交互', '控件事件', '滚动条', '命令']
摘要由CSDN通过智能技术生成

题目链接:http://www.patest.cn/contests/pat-a-practise/1065


题面:

1065. A+B and C (64bit) (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
HOU, Qiming

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false
题目大意:

  判断A+B是否大于C。


解题:

   因为直接计算会爆long long,先减再加也不行,那么就取除10部分计算,模10部分分别计算。最后把结果整理一下判断即可。


代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cstring>
using namespace std;
#define LL long long 
int main()
{
	int n;
    LL a,ab1,ab2,b,c,c1,c2,t1,t2;
    cin>>n;
    for(int i=1;i<=n;i++)
    {
    	cout<<"Case #"<<i<<": ";
    	cin>>a>>b>>c;
        ab1=a/10+b/10;
        ab2=a%10+b%10;
        c1=c/10;
        c2=c%10;
        t1=ab1-c1;
        t2=ab2-c2;
        t1+=(t2/10);
        t2%=10;
        if(t2<0)
          t2+=10,t1-=1;
    	if(t1<0||(t1==0&&t2==0))cout<<"false\n";
    	else cout<<"true\n";
    }
	return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值