PAT-PAT (Advanced Level) Practise 1018. Public Bike Management (30) 【四星级】

题目链接:http://www.patest.cn/contests/pat-a-practise/1018


题目链接:

1018. Public Bike Management (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.


Figure 1

Figure 1 illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S3, we have 2 different shortest paths:

1. PBMC -> S1 -> S3. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S1 and then take 5 bikes to S3, so that both stations will be in perfect conditions.

2. PBMC -> S2 -> S3. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: Cmax (<= 100), always an even number, is the maximum capacity of each station; N (<= 500), the total number of stations; Sp, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers Ci(i=1,...N) where each Ci is the current number of bikes at Si respectively. Then M lines follow, each contains 3 numbers: Si, Sj, and Tij which describe the time Tij taken to move betwen stations Si and Sj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0->S1->...->Sp. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of Spis adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:
10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1
Sample Output:
3 0->2->3 0

题目大意:

    要求从起点到目标点,找到一条路径,使得该路径最短,并且 使得该路径上的点的车数量都达到既定值。若存在多条,则要找到需要从源点运车数最少的,若还存在多条,则选择为那条到达目标点之后,多出的车最少的路径。这里被坑死了,牛客网的数据没有考虑到第二层。


解题:

   dfs搜索,到达目标点比较,比较规则详见代码,需要更新,则更新路径。


代码:

#include <iostream>
#include <vector>
#include <cstdio>
#include <cstring>
#define inf 1000000000
using namespace std;
int  num[510],tmp[510],path[510];
int mincost,minbike,maxbike;
int s,c,tt;
vector <int> r[510];
int  mapp[510][510];
bool vis[510];
int  min(int a,int b)
{
  return a<b?a:b;
}
void dfs(int x,int extr,int les,int step,int cost)
{
  int temp;
  vis[x]=1;
  tmp[step]=x;
  if(num[x]>=c)
  {
    extr+=num[x]-c;
  }
  else
  {
    temp=c-num[x];
    if(extr>=temp)
    {
      extr-=temp;
    }
    else
    {
      les+=temp-extr;
      extr=0;
    }
  }
  if(x==s)
  {
    if(cost<mincost)
    {
      mincost=cost;
      minbike=les;
      maxbike=extr;
      tt=step;
      for(int i=0;i<=tt;i++)
        path[i]=tmp[i];
    }
    else if(cost==mincost)
    {
      if(minbike>les)
      {
        minbike=les;
        maxbike=extr;
        tt=step;
         for(int i=0;i<=tt;i++)
            path[i]=tmp[i];
      }
      else if(minbike==les)
      {
        if(extr<maxbike)
        {
          maxbike=extr;
          tt=step;
              for(int i=0;i<=tt;i++)
                path[i]=tmp[i];
        }
      }
    }
    return;
  }
  for(int i=0;i<r[x].size();i++)
  {
    if(!vis[r[x][i]])
    {
      dfs(r[x][i],extr,les,step+1,cost+mapp[x][r[x][i]]);
      vis[r[x][i]]=0;
    }
  }
}
int main()
{
  int n,m,a,b,d;
  scanf("%d%d%d%d",&c,&n,&s,&m);
  for(int i=1;i<=n;i++)
    scanf("%d",&num[i]);
    for(int i=0;i<=n;i++)
      for(int j=0;j<=n;j++)
        mapp[i][j]=inf;
    c/=2;
    mincost=inf;
    minbike=inf;
    memset(vis,0,sizeof(vis));
    for(int i=0;i<m;i++)
    {
      scanf("%d%d%d",&a,&b,&d);
      mapp[a][b]=min(mapp[a][b],d);
      mapp[b][a]=mapp[a][b];
      r[a].push_back(b);
      r[b].push_back(a);
    }
    vis[0]=1;
    tmp[0]=0;
    for(int i=0;i<r[0].size();i++)
    {
      dfs(r[0][i],0,0,1,mapp[0][r[0][i]]);
        vis[r[0][i]]=0;
    }
    printf("%d 0",minbike);
    for(int i=1;i<=tt;i++)
      printf("->%d",path[i]);
    printf(" %d\n",maxbike);
  return 0;
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值