UVA 10970 Big Chocolate(水题)

题面:

Big Chocolate

Mohammad has recently visited Switzerland. As he loves his friends very much, he decided to buy some chocolate for them, but as this fine chocolate is very expensive(You know Mohammad is a little BIT stingy!), he could only afford buying one chocolate, albeit a very big one (part of it can be seen in figure 1) for all of them as a souvenir. Now, he wants to give each of his friends exactly one part of this chocolate and as he believes all human beings are equal (!), he wants to split it into equal parts.

The chocolate is an 10970 <wbr>- <wbr>Big <wbr>Chocolate <wbr>(AC)  rectangle constructed from 10970 <wbr>- <wbr>Big <wbr>Chocolate <wbr>(AC)  unit-sized squares. You can assume that Mohammad has also 10970 <wbr>- <wbr>Big <wbr>Chocolate <wbr>(AC)  friends waiting to receive their piece of chocolate.

To split the chocolate, Mohammad can cut it in vertical or horizontal direction (through the lines that separate the squares). Then, he should do the same with each part separately until he reaches 10970 <wbr>- <wbr>Big <wbr>Chocolate <wbr>(AC)  unit size pieces of chocolate. Unfortunately, because he is a little lazy, he wants to use the minimum number of cuts required to accomplish this task.

Your goal is to tell him the minimum number of cuts needed to split all of the chocolate squares apart.

 

10970 <wbr>- <wbr>Big <wbr>Chocolate <wbr>(AC)

Figure 1. Mohammad’s chocolate

 

The Input

The input consists of several test cases. In each line of input, there are two integers 10970 <wbr>- <wbr>Big <wbr>Chocolate <wbr>(AC) , the number of rows in the chocolate and 10970 <wbr>- <wbr>Big <wbr>Chocolate <wbr>(AC) , the number of columns in the chocolate. The input should be processed until end of file is encountered.

 

The Output

For each line of input, your program should produce one line of output containing an integer indicating the minimum number of cuts needed to split the entire chocolate into unit size pieces.

 

Sample Input

2 2

1 1

1 5

 

Sample Output

3

0

4


题面:

    给定一块巧克力,问最少切多少刀,可以切成MxN块,分开两块不可以一起切。


解题:

    算是找规律吧,N*N的切的数量是以2阶等差递增的,而N*M的可以从N*N推出来,每次增加N,(N<M)


代码:

#include <iostream>
#include <algorithm>
#include <vector>
#include <string>
#include <cstdio>
#include <map> 
using namespace std;
int start[310]={0,0};
int main()
{
for(int i=2;i<=300;i++)
start[i]=start[i-1]+2*i-1;
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
       if(n<=m)
    printf("%d\n",start[n]+(m-n)*n);
  else
    printf("%d\n",start[m]+(n-m)*m);
    }
return 0;
}

#include <iostream>
#include <algorithm>
#include <vector>
#include <string>
#include <cstdio>
#include <map> 
using namespace std;
int start[310]={0,0};
int main()
{
	for(int i=2;i<=300;i++)
		start[i]=start[i-1]+2*i-1;
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
       if(n<=m)
	     printf("%d\n",start[n]+(m-n)*n);
	   else
	     printf("%d\n",start[m]+(n-m)*m);	
    }
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值