题目连接:POJ 2104 kth number
You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?"
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.
Input
The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 10 9 by their absolute values --- the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).
Output
For each question output the answer to it --- the k-th number in sorted a[i...j] segment.
Sample Input
7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3
Sample Output
5
6
3
Hint
This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.
给你一数列,q个询问,询问某个区间第k大的数,主席树板子题,
不会主席树的可以戳这里https://blog.csdn.net/Daxian911/article/details/89075748
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 1e5 + 10;
int a[maxn], b[maxn], root[maxn];
int n, q, tot = 0;
struct node{
int l, r;
int val;
}e[maxn * 22];
void build(int l, int r, int &cur){
cur = ++tot;
e[cur].val = 0;
if(l == r) return;
int mid = l + r >> 1;
build(l, mid, e[cur].l);
build(mid + 1, r, e[cur].r);
}
void update(int pre, int &cur, int l, int r, int pos){
cur = ++tot;
e[cur] = e[pre];
e[cur].val++;
if(l == r) return;
int mid = l + r >> 1;
if(pos <= mid){
update(e[pre].l, e[cur].l, l, mid, pos);
}
else {
update(e[pre].r, e[cur].r, mid + 1, r, pos);
}
}
int query(int pre, int cur, int l, int r, int val){
if(l == r) {
return l;
}
int sum = e[e[cur].l].val - e[e[pre].l].val;
int mid = l + r >> 1;
if(val <= sum) {
return query(e[pre].l, e[cur].l, l, mid, val);
}
else {
return query(e[pre].r, e[cur].r, mid + 1, r, val - sum);
}
}
int main(){
scanf("%d%d", &n, &q);
for(int i = 1; i <= n; i++) {
scanf("%d", &a[i]);
b[i] = a[i];
}
sort(b + 1, b + n + 1);
int len = unique(b + 1, b + n + 1) - (b + 1);
build(1, len, root[0]);
for(int i = 1; i <= n; i++) {
int x = lower_bound(b + 1, b + len + 1, a[i]) - b;
update(root[i - 1], root[i], 1, len, x);
}
while(q--) {
int l, r, val;
scanf("%d%d%d", &l, &r, &val);
printf("%d\n", b[query(root[l - 1], root[r], 1, len, val)]);
}
return 0;
}