1149 Dangerous Goods Packaging (25分)

When shipping goods with containers, we have to be careful not to pack some incompatible goods into the same container, or we might get ourselves in serious trouble. For example, oxidizing agent (氧化剂) must not be packed with flammable liquid (易燃液体), or it can cause explosion.

Now you are given a long list of incompatible goods, and several lists of goods to be shipped. You are supposed to tell if all the goods in a list can be packed into the same container.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: N (≤10^​4
​​ ), the number of pairs of incompatible goods, and M (≤100), the number of lists of goods to be shipped.
Then two blocks follow. The first block contains N pairs of incompatible goods, each pair occupies a line; and the second one contains M lists of goods to be shipped, each list occupies a line in the following format:
K G[1] G[2] … G[K]
where K (≤1,000) is the number of goods and G[i]'s are the IDs of the goods. To make it simple, each good is represented by a 5-digit ID number. All the numbers in a line are separated by spaces.

Output Specification:

For each shipping list, print in a line Yes if there are no incompatible goods in the list, or No if not.

Sample Input:

6 3
20001 20002
20003 20004
20005 20006
20003 20001
20005 20004
20004 20006
4 00001 20004 00002 20003
5 98823 20002 20003 20006 10010
3 12345 67890 23333

Sample Output:

No
Yes
Yes

题⽬⼤意:

集装箱运输货物时,我们必须特别⼩⼼,不能把不相容的货物装在⼀只箱⼦⾥。⽐如氧化
剂绝对不能跟易燃液体同箱,否则很容易造成爆炸。给定⼀张不相容物品的清单,需要你检查每⼀张
集装箱货品清单,判断它们是否能装在同⼀只箱⼦⾥。对每箱货物清单,判断是否可以安全运输。如
果没有不相容物品,则在⼀⾏中输出 Yes,否则输出 No

分析:

⽤map存储每⼀个货物的所有不兼容货物,在判断给出的⼀堆货物是否是相容的时候,判断任
⼀货物的不兼容货物是否在这堆货物中,如果存在不兼容的货物,则这堆货物不能相容,如果遍历完
所有的货物,都找不到不兼容的两个货物,则这堆货物就是兼容的。
注意:货物的不兼容可以是一对多关系,所以不能使用普通的数组hash

代码:[hash,map的应用]

//1149 Dangerous Goods Packaging (25分)
#include<iostream>
#include<vector>
#include<map>
using namespace std;
map<int,vector<int>> incom;
int main()
{
	int n,m;
	cin>>n>>m;
	for(int i=0; i<n; i++)
	{
		int g1,g2;
		cin>>g1>>g2;
		incom[g1].push_back(g2);
		incom[g2].push_back(g1);
	}
	for(int i=0; i<m; i++)
	{
		int num;
		bool flag=false;
		bool vis[100000]={false};//定义写在这里相当于初始化
		cin>>num;
		vector<int> ship(num);
		for(int j=0; j<num; j++)
		{
			cin>>ship[j];
			vis[ship[j]]=true;//表示在列表中存在 
		}
		for(int k=0; k<ship.size(); k++)
		{
			for(int l=0; l<incom[ship[k]].size(); l++)
			{
				if (vis[incom[ship[k]][l]]==1)//与之发生危险的货物也存在 
					flag=true;
			}
		}
		printf("%s\n",flag?"No":"Yes");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值