1017. A除以B

本题要求计算A/B,其中A是不超过1000位的正整数,B是1位正整数。你需要输出商数Q和余数R,使得A = B * Q + R成立。

输入格式:

输入在1行中依次给出A和B,中间以1空格分隔。

输出格式:

在1行中依次输出Q和R,中间以1空格分隔。

输入样例:
123456789050987654321 7
输出样例:
17636684150141093474 3
此题需要注意输出是第一位是0的问题;

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int main(){
    int i,j=0;
    char A[10001],str[1001];
    //存放被除数和商; 
    int  B;
    int temp=0,s;
    //存放每一位的商和余数; 
    scanf("%s",A);
    scanf("%d",&B);
    for(i=0;i<strlen(A);i++){
        s=(temp*10+(A[i]-'0'))/B;
        str[j++] = s+'0';
        temp = ((temp*10)+(A[i]-'0'))%B;
    }
    str[j]='\0';
    for(i=0;i<strlen(str);i++){
        if(i==0){
                if(str[i]=='0'){
                    if(strlen(str)==1){
                        printf("%c",str[i]);        
                    }
                    else{
                    }
                }
                else{
                    printf("%c",str[i]);
                }
        }
        else{
            printf("%c",str[i]);
        }
    }
    printf(" %d",temp);
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值