nyoj 248 BUYING FEED

BUYING FEED

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 4
描述

Farmer John needs to travel to town to pick up K (1 <= K <= 100)pounds of feed. Driving D miles with K pounds of feed in his truck costs D*K cents.

The county feed lot has N (1 <= N<= 100) stores (conveniently numbered 1..N) that sell feed. Each store is located on a segment of the X axis whose length is E (1 <= E <= 350). Store i is at location X_i (0 < X_i < E) on the number line and can sell John as much as F_i (1 <= F_i <= 100) pounds of feed at a cost of C_i (1 <= C_i <= 1,000,000) cents per pound.
Amazingly, a given point on  the X axis might have more than one store.

Farmer John  starts  at location 0 on this number line and can drive only in the positive direction, ultimately arriving at location E, with at least K pounds of feed. He can stop at any of the feed stores along the way and buy any amount of feed up to the the store's limit.  What is the minimum amount Farmer John has to pay to buy and transport the K pounds of feed? Farmer John
knows there is a solution.
 Consider a sample where Farmer John  needs two pounds of feed from three stores (locations: 1, 3, and 4) on a number line whose range is 0..5:     
0   1   2  3   4   5
    
---------------------------------
         
1       1   1                Available pounds of feed
         
1       2   2               Cents per pound

It is best for John to buy one pound of feed from both the second and third stores. He must pay two cents to buy each pound of feed for a total cost of 4. When John travels from 3 to 4 he is moving 1 unit of length and he has 1 pound of feed so he must pay1*1 = 1 cents.

When John travels from 4 to 5 heis moving one unit and he has 2 pounds of feed so he must pay 1*2 = 2 cents. The total cost is 4+1+2 = 7 cents.

输入
The first line of input contains a number c giving the number of cases that follow
There are multi test cases ending with EOF.
Each case starts with a line containing three space-separated integers: K, E, and N
Then N lines follow :every line contains three space-separated integers: Xi Fi Ci
输出
For each case,Output A single integer that is the minimum cost for FJ to buy and transport the feed
样例输入
12 5 3                 3 1 24 1 21 1 1
样例输出
7
来源

第三届河南省程序设计大赛

这道题真的是,神坑啊!!!刚开始竟然以为是动态规划里的多重背包问题(把K当成背包容量,Fi当成物品最多可用的次数,N当成物品的种类),最后一只调试不出来,想过贪心,但是因为车不能返回来把贪心给Pass了,但是忽略了一个问题,就是把单个商品的花费求出来之后小的就还是小的,就算是第五个物品的消耗最小,那也可以最后路过的时候给买了,由此也可以看出贪心算法只是一个策略,并没有太多的复杂过程,就像导弹拦截系统装置一样,不需要挨个考虑第几个导弹的高度,只需要在数组中找到比上一个高度小的就可以

这道题属于部分背包问题,与动态规划的区别在于,这种背包问题中的物品可以分割,但是动态规划中的物品不可以分割,而且,emmmm。。。暂时分不清他与多重背包有什么区别,如果有大神可以指导一下,将不胜感激。。。

#include<stdio.h>
#include<algorithm>
using namespace std;
struct Node{
	int Xi,Fi,Ci,sum;
}a[110];
int cmp(Node x,Node y){
	return x.sum<y.sum;
}
int main(){
	int C,K,E,N;
	scanf("%d",&C);
	while(C--){
		scanf("%d %d %d",&K,&E,&N);
		for(int i=0;i<N;i++){
			scanf("%d %d %d",&a[i].Xi,&a[i].Fi,&a[i].Ci);
			a[i].sum=E-a[i].Xi+a[i].Ci;//这里计算的是单价,如果按照总的来算的话,也可能导致因为磅数多而结果增大
		}
		sort(a,a+N,cmp);
		int ans=0;
		for(int i=0;i<N;i++){
			if(a[i].Fi<=K){
				ans+=a[i].Fi*a[i].sum;
				K-=a[i].Fi;
			}
			else if(K>=0){//这里记得K>=0,不然的话如果出现负数的情况就不好了
				ans+=K*a[i].sum;
				K=0;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值