xynuoj 1972 坦克大战

1972: 坦克大战

时间限制: 1 Sec   内存限制: 64 MB
提交: 39   解决: 20
您该题的状态:已完成
[提交][状态][讨论版]

题目描述

Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now. 

What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture).

Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?

输入

The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target), 'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.

输出

For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.

样例输入

3 4
YBEB
EERE
SSTE
0 0

样例输出

8

提示

nyoj284

来源

nyoj搜索 nyoj图论 

这个用普通的队列做不出来,不知道为什么

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
char map[310][310];//记录图 
int visit[310][310];//记录点是否被访问过
int M,N;
struct Node{
	int m,n,step;
	friend bool operator <(Node n1,Node n2)
    {
        return n1.step>n2.step;//按步数从小到大排序 
    }
}s,e; 
int bfs(int x,int y){
	memset(visit,0,sizeof(visit));
	priority_queue<Node>q;
	s.m=x;
	s.n=y;
	s.step=0;
	q.push(s);
	visit[x][y]=1;
	Node s1,s2;
	while(!q.empty()){
		s1=q.top();
		q.pop();
		printf("%d %d %d\n",s1.m,s1.n,s1.step); 
		for(int i=0;i<4;i++){
			s2=s1;
			s2.m+=dir[i][0];
			s2.n+=dir[i][1];
			if(!visit[s2.m][s2.n]&&map[s2.m][s2.n]!='S'&&map[s2.m][s2.n]!='R'&&s2.m>0&&s2.m<=M&&s2.n>0&&s2.n<=N){
				if(map[s2.m][s2.n]=='T'){
					return s2.step+1;
				}
				else if(map[s2.m][s2.n]=='E'){
					visit[s2.m][s2.n]=1;
					s2.step=s1.step+1;
					q.push(s2);
				}
				else if(map[s2.m][s2.n]=='B'){
					visit[s2.m][s2.n]=1;
					s2.step=s1.step+2;
					q.push(s2);
				}
			}
		}
	}
	return -1;
} 
int main(){
	while(scanf("%d %d",&M,&N)!=EOF&&M!=0&&N!=0){
		getchar();
		for(int i=1;i<=M;i++){
			for(int j=1;j<=N;j++){
				scanf("%c",&map[i][j]);
				if(map[i][j]=='Y'){
					s.m=i;
					s.n=j;
				}
				if(map[i][j]=='T'){
					e.m=i;
					e.n=j;
				}
			}
			getchar();
		}
		printf("%d\n",bfs(s.m,s.n));
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值