hdoj 1020 Encoding

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 52209    Accepted Submission(s): 23212


Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.
 

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 

Output
For each test case, output the encoded string in a line.
 

Sample Input
 
 
2 ABC ABBCCC
 

Sample Output
 
 
ABC A2B3C

刚开始理解错题意了,以为是让把给的字符串中的单词统计数目然后输出,但是其实不是,这道题是让把相邻的并且相同的字符合并输出(数目+字符),然后这个题目可以这么比较,直接用一个num统计数目(初始化为1),然后将当前字符与它后边的字符比较,看是否相同,相同的话加1并且继续执行程序,不相同的话就直接输出来就好了,不过输出后记得要把num赋值为1,不然会让下一个字符数目多计算

#include<stdio.h>
#include<string.h> 
int main(){
	//freopen("test.in","r",stdin);
	int N;
	char str[10005];
	scanf("%d",&N);
	while(N--){
		scanf("%s",str);
		int len=strlen(str);
		int num=1;
		for(int i=0;i<len;i++){
			if(str[i]==str[i+1])
			num++;
			else{
				if(num==1) printf("%c",str[i]);
				else
				printf("%d%c",num,str[i]);
				num=1;
			}
		}
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值