HDOJ1020 Encoding

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 49366    Accepted Submission(s): 21998


Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.
 

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 

Output
For each test case, output the encoded string in a line.
 

Sample Input
  
  
2 ABC ABBCCC
 

Sample Output
  
  
ABC A2B3C
 
题意很好理解,就是连着的相同字符只输出一个,前面带一个该字符的个数。
如果是1就可以省略。可以先new 一个空字符串string ,将给定的字符串一个个处理判断,使用count计算个数。
然后加到string.
下面AC代码:
import java.util.Scanner;

public class Main{
	private static Scanner scanner;
	public static void main(String[] args) {
		scanner = new Scanner(System.in);
		int n = scanner.nextInt();
		while(n-->0){
			String string = scanner.next();
			String res = "";
			char[] arr = string.toCharArray();
			int count = 1;
			for (int i = 1; i < arr.length; i++) {
				if(arr[i] == arr[i-1]){
					count++;
				}else {
					if(count == 1){
						res = res+arr[i-1];
					}else {
						res = res+count+arr[i-1];
					}
					count = 1;
				}
			}
			if(count == 1){
				res = res+arr[arr.length-1];
			}else {
				res = res+count+arr[arr.length-1];
			}
			System.out.println(res);
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值