Problem 1001

11 篇文章 0 订阅

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 184771    Accepted Submission(s): 43962


Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 

Input
The input will consist of a series of integers n, one integer per line.
 

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 

Sample Input
  
  
1 100
 

Sample Output
  
  
1 5050
 

Author
DOOM III

因为n很大的时候n*(n+1)的值会溢出。可以判断奇偶然后先做除法。
注意这句:You may assume the result will be in the range of 32-bit signed integer.
要求是你的结果要在32位有符号整型范围内。假设n*(n+1)/2的结果刚好满足32位。但是在做除法前
n*(n+1)的结果就超过了32位。
来自:http://zhidao.baidu.com/question/502897991.html&from=emailmsg#submit
感谢   DN_海伦泰勒  



#include <iostream>
using namespace std;
void main()
{int n;
while(cin>>n) 
{	
	
	int i,sum=0;
	for(i=1;i<=n;i++) sum=sum+i;
	cout<<sum<<endl<<endl;
}
}

#include <iostream>
using namespace std;
void main()
{int n;
while(cin>>n) 
{	
cout<<n*(n+1)/2<<endl<<endl;
}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值