【GPLT 二阶题目集】L2-012 关于堆的判断

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

x is the root:x是根结点;
x and y are siblings:x和y是兄弟结点;
x is the parent of y:x是y的父结点;
x is a child of y:x是y的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F。

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T

#include <iostream>
#include <string>
#include <map>
using namespace std;

const int N = 1e5 + 10;
const int MAX = 0x3f3f3f3f;
int n, m, tree[N]; //全局变量自动初始化0
map<int, int> num; //值,编号

void creattree(int x)
{
    while (x != 1 && tree[x] < tree[x / 2])
    {
        swap(tree[x], tree[x / 2]);
        x /= 2;
    }
    return;
}

//int findd(int x) //找值对应的编号
//{
//    for (int i = 1; i <= n; i++)
//    {
//        if (tree[i] == x)
//            return i;
//    }
//}

int main()
{
    fill(tree, tree + N, MAX);
    cin >> n >> m;
    for (int i = 1; i <= n; i++)
    { //升序储存,下标1~n
        cin >> tree[i];
        creattree(i);
    }
    for (int i = 1; i <= n; i++)
        num[tree[i]] = i;
    string str;
    int a, b;
    while (m--)
    {
        cin >> a >> str;
        if (str == "and") //a和b是兄弟结点?(仅考虑双亲相同)
        {
            cin >> b >> str >> str;
            if (num[a] / 2 == num[b] / 2)
                cout << "T" << endl;
            else
                cout << "F" << endl;
        }
        else //is
        {
            cin >> str >> str;
            if (str == "child") //a是b的一个子结点?(仅考虑相邻两代)
            {
                cin >> str >> b;
                if (num[a] / 2 == num[b])
                    cout << "T" << endl;
                else
                    cout << "F" << endl;
            }
            else if (str == "root") //a是根结点?
            {
                if (a == tree[1]) //写成tree[0],测试点1、2、3答案错误,说明测试点0很可能是样例
                    cout << "T" << endl;
                else
                    cout << "F" << endl;
            }
            else  //a是b的父结点?
            {
                cin >> str >> b;
                if (num[a] == num[b] / 2)
                    cout << "T" << endl;
                else
                    cout << "F" << endl;
            }
        }
    }
    return 0;
}

 注意事项:

该题不是给了一个无序堆再插入数据,而是可以直接建堆,因此难度有所降低。

如有问题,欢迎提出。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

花辞树dor

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值