L2-012 关于堆的判断 分数 25

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T

代码展示 

#include<bits/stdc++.h>
using namespace std;
int h[10010];
int n,m;
void up(int x)  //比较建堆
{
	if(x==1)return;
	while(h[x]<h[x/2]&&x/2)
	{
		swap(h[x],h[x/2]);
		x/=2;
	 } 
}
int find(int x)   //查找数据在堆中所在的位置
{
	for(int i=1;i<=n;i++)if(h[i]==x)return i;
}
void Is(string s)  //判断输入是否F T 
{
	if(s.find(" is the root")!=-1)  //针对例题第一句
	{
		string s1=s.substr(0,s.find(" is"));
		string s2=to_string(h[1]);
		if(s1==s2)cout<<"T";
		else cout<<"F";
		return ;
	}
	if(s.find(" and ")!=-1)    /针对例题第二句
	{
		string s1=s.substr(0,s.find(" and"));
		string s2=s.substr(s.find("and ")+4,s.find(" are")-s.find("and ")-4);
		int x1=find(stod(s1));
		int x2=find(stod(s2));
	//	cout<<x1<<" "<<x2<<endl;
		if(x1/2==x2/2)cout<<"T";
		else cout<<"F";	
		return ;
	}
	if(s.find("parent")!=-1)   //针对例题第三句
	{
		string s1=s.substr(0,s.find(" is"));
		string s2=s.substr(s.find("of ")+3);
		int x1=find(stod(s1));
		int x2=find(stod(s2));
		if(x2/2==x1)cout<<"T";
		else cout<<"F";
		return ;
	}
	if(s.find("child")!=-1)   //针对例题第四句
	{
		string s1=s.substr(0,s.find(" is"));
		string s2=s.substr(s.find("of ")+3);
		int x1=find(stod(s1));
		int x2=find(stod(s2));
		if(x2==x1/2)cout<<"T";
		else cout<<"F";
		return ;
	}
}
int main()
{

	cin>>n>>m;
	for(int i=1;i<=n;i++)
	{
		cin>>h[i];
		up(i);
	}
	getchar();    //吃一个回车,否则少一个输入
//	for(int i=1;i<=n;i++)cout<<h[i]<<" ";
	for(int i=1;i<=m;i++)
	{
		string s;
		getline(cin,s);
		//cout<<s<<endl;
		Is(s);
		if(i!=m)cout<<endl;
	}
 }

结果测试

 

 

  • 7
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值